Update babel to 0.15 add a sample configuration file
[openwrt/svn-archive/archive.git] / net / squid / Makefile
index 4d0989f206c92c97e3876115b62cde2ffcd3f92d..a075e7577d3d64f4c32c8a06c272eb6166560c0f 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.5.STABLE13
+PKG_VERSION:=2.6.STABLE14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.5/
-PKG_MD5SUM:=3e64468e123be1246d17486dab6bee87
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.6/
+PKG_MD5SUM:=eadb138d48320df8b99349121159c6bf
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -25,21 +24,34 @@ include $(INCLUDE_DIR)/package.mk
 define Package/squid/Default
   SECTION:=net
   CATEGORY:=Network
-  URL:=http://www.squid-cache.org
+  URL:=http://www.squid-cache.org/
 endef
 
 define Package/squid
   $(call Package/squid/Default)
   MENU:=1
-  DEPENDS:=+libopenssl +libpthread
+  DEPENDS:=+libopenssl +libpthread @LINUX_2_6
   TITLE:=full-featured Web proxy cache
-  DESCRIPTION:=\
-       Squid is a high-performance proxy caching server for web clients, \\\
-       supporting FTP, gopher, and HTTP data objects. Unlike traditional \\\
-       caching software, Squid handles all requests in a single, \\\
+endef
+
+define Package/squid/description
+       Squid is a high-performance proxy caching server for web clients, 
+       supporting FTP, gopher, and HTTP data objects. Unlike traditional 
+       caching software, Squid handles all requests in a single, 
        non-blocking, I/O-driven process.
 endef
 
+define Package/squid/conffiles
+/etc/squid/mime.conf
+/etc/squid/squid.conf
+endef
+
+define Package/squid-mod-cachemgr
+  $(call Package/squid/Default)
+  DEPENDS:=squid
+  TITLE:=Web based proxy manager and reporting tool
+endef
+
 define Package/squid-mod-basic-auth-getpwnam
   $(call Package/squid/Default)
   DEPENDS:=squid
@@ -58,12 +70,6 @@ define Package/squid-mod-basic-auth-smb
   TITLE:=Samba basic authentication helper
 endef
 
-define Package/squid-mod-basic-auth-winbind
-  $(call Package/squid/Default)
-  DEPENDS:=squid
-  TITLE:=Winbind basic authentication helper
-endef
-
 define Package/squid-mod-digest-auth-password
   $(call Package/squid/Default)
   DEPENDS:=squid
@@ -82,12 +88,6 @@ define Package/squid-mod-external-acl-unix-group
   TITLE:=Unix group external ACL helper
 endef
 
-define Package/squid-mod-external-acl-winbind-group
-  $(call Package/squid/Default)
-  DEPENDS:=squid
-  TITLE:=Winbind group external ACL helper
-endef
-
 define Package/squid-mod-ntlm-auth-fakeauth
   $(call Package/squid/Default)
   DEPENDS:=squid
@@ -100,12 +100,6 @@ define Package/squid-mod-ntlm-auth-smb-auth
   TITLE:=Samba NTLM authentication helper
 endef
 
-define Package/squid-mod-ntlm-auth-winbind-auth
-  $(call Package/squid/Default)
-  DEPENDS:=squid
-  TITLE:=Winbind NTLM authentication helper
-endef
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --datadir=/usr/share/squid \
@@ -113,7 +107,6 @@ define Build/Configure
                --sysconfdir=/etc/squid \
                --enable-shared \
                --enable-static \
-               --with-gnu-ld \
                --enable-x-accelerator-vary \
                --with-pthreads \
                --with-dl \
@@ -134,14 +127,16 @@ define Build/Configure
                --enable-useragent-log \
                --with-openssl=$(STAGING_DIR)/usr \
                --enable-auth="basic digest ntlm" \
-               --enable-basic-auth-helpers="getpwnam NCSA SMB winbind" \
-               --enable-ntlm-auth-helpers="fakeauth SMB winbind" \
+               --enable-basic-auth-helpers="getpwnam NCSA SMB" \
+               --enable-ntlm-auth-helpers="fakeauth SMB" \
                --enable-digest-auth-helpers="password" \
-               --enable-external-acl-helpers="ip_user unix_group winbind_group" \
+               --enable-external-acl-helpers="ip_user unix_group" \
+               --enable-epoll \
+               --with-maxfd=4096 \
        )
 endef
        
-define Build/Compile   
+define Build/Compile
        # pass INCLUDES to compile host sources against our OpenSSL, not the host one
        $(MAKE) -C $(PKG_BUILD_DIR)/lib \
                INCLUDES="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -151,34 +146,44 @@ define Build/Compile
                all install
 endef
 
-define Package/squid/install   
+define BuildPlugin
+  define Package/$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib/squid
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/$(2) $$(1)/usr/lib/squid/
+  endef
+
+  $$(eval $$(call BuildPackage,$(1)))
+endef
+
+define Package/squid/install
        $(INSTALL_DIR) $(1)/etc/squid
        $(CP) $(PKG_INSTALL_DIR)/etc/squid/mime.conf $(1)/etc/squid/
        $(CP) $(PKG_INSTALL_DIR)/etc/squid/squid.conf $(1)/etc/squid/
        $(INSTALL_DIR) $(1)/usr/share/squid
        $(CP) $(PKG_INSTALL_DIR)/usr/share/squid/* $(1)/usr/share/squid/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/squid
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger} $(1)/usr/lib/squid/
 endef
 
-define BuildPlugin
-  define Package/$(1)/install
-       $(INSTALL_DIR) $$(1)/usr/lib/squid
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/$(2) $$(1)/usr/lib/squid/
-  endef
-
-  $$(eval $$(call BuildPackage,$(1)))
+define Package/squid-mod-cachemgr/install
+       $(INSTALL_DIR) $(1)/www/cgi-bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/cachemgr.cgi $(1)/www/cgi-bin/
 endef
 
 $(eval $(call BuildPackage,squid))
+$(eval $(call BuildPackage,squid-mod-cachemgr))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-getpwnam,getpwname_auth))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-ncsa,ncsa_auth))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-smb,smb_auth))
-$(eval $(call BuildPlugin,squid-mod-basic-auth-winbind,wb_auth))
 $(eval $(call BuildPlugin,squid-mod-digest-auth-password,digest_pw_auth))
 $(eval $(call BuildPlugin,squid-mod-external-acl-ip-user,ip_user_check))
 $(eval $(call BuildPlugin,squid-mod-external-acl-unix-group,squid_unix_group))
-$(eval $(call BuildPlugin,squid-mod-external-acl-winbind-group,wb_group))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-fakeauth,fakeauth_auth))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-smb-auth,ntlm_auth))
-$(eval $(call BuildPlugin,squid-mod-ntlm-auth-winbind-auth,wb_ntlmauth))
+
+$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \
+       $(PKG_NAME) requires the openssl development (named like libssl-dev, \
+       depending of your package manager) package be installed on the host-system. \
+))