[packages] ptpd: fix initscript file name, fix description, add copyright header...
[openwrt/svn-archive/archive.git] / net / ssltunnel / Makefile
index 952844e167bb80bad89cfd30aabca385cfb513af..84ddadbe0f9abdfc7fe1c1c80f62489fc87b81d8 100644 (file)
@@ -4,21 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ssltunnel
-PKG_VERSION:=1.15
+PKG_VERSION:=1.16
 PKG_RELEASE:=1
 
 PKG_SOURCE:=${PKG_NAME}-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hsc.fr/ressources/outils/ssltunnel/download
-PKG_MD5SUM:=bfe529edb9b6c97bc03d213676b1f35d
-PKG_CAT:=zcat
+PKG_MD5SUM:=4039b50566a33a4077883ea974e476d5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,8 +23,18 @@ define Package/ssltunnel
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+ppp +libopenssl
-  TITLE:=A PPP over SSL vpn tool
+  TITLE:=A PPP over SSL VPN tool
   URL:=http://www.hsc.fr/ressources/outils/ssltunnel/index.html
+  SUBMENU:=VPN
+endef
+
+define Package/ssltunnel/description
+       SSLTunnel is a client/server program to create a PPP connection over a
+       SSL/TLS session.
+       Client and server are mutually authenticated using a X509 certificate,
+       PPP packets are then encrypted/decrypted realtime on each side.
+       It's possible to use ssltunnel to connect a machine to another, a
+       machine with a network or two networks sets.
 endef
 
 define Build/Configure
@@ -38,19 +45,13 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/ssltunnel/install       
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/bin/pppclient $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/pppwho $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/lib
-       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppserver $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pppclient $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppwho $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/pppserver $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,ssltunnel))