Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / net / sstp-client / Makefile
index baea8d2be27bb3c70c8e9123645516e24ddfe77b..7ae4a4bc2c7f9e02b33979d65970969b2c8e681d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sstp-client
-PKG_VERSION:=1.0.10
+PKG_VERSION:=1.0.11
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/sstp-client/$(PKG_VERSION)
-PKG_MD5SUM:=5f290355187e5ce0423fb7e388e65b9d
+PKG_HASH:=1b851b504030ed5522ced431217a5c700b35e8bb72d6f5b40b006c7becb8fb20
 PKG_LICENSE=GPLv2
 
 include $(INCLUDE_DIR)/package.mk
@@ -23,31 +23,39 @@ TARGET_CPPFLAGS += -I$(PKG_BUILD_DIR)/include
 define Package/sstp-client
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=VPN
   DEPENDS=+libevent2 +libopenssl +ppp
-  TITLE:=SSTP is Microsofts Remote Access Solution for PPP over SSL
+  TITLE:=SSTP-Client is a SSTP client for Linux.
   URL:=http://sstp-client.sourceforge.net/
   MAINTAINER:=Federico Di Marco <fededim@gmail.com>
 endef
 
 define Package/sstp-client/description
- It can be used instead of PPTP or L2TP, and is only available with Windows Vista/7 connecting to a Windows 2008 Server. The advantage of SSTP  compared to PPTP and L2TP is that it cannot be easily blocked by firewalls since the traffic is transmitted over HTTPS on port 443.
- Windows Vista/7 uses SSTP whenever PPTP or L2TP cannot be established. For further information on SSTP check out wikipedia's article on Secure Socket Tunneling Protocol.
+The advantage of SSTP compared to other vpn protocols like PPTP and L2TP is that it cannot be easily blocked by firewalls since the traffic is transmitted over HTTPS on port 443.
+This software has a similar commandline and configuration to the standard linux pptp-client software.
+
+Features:
+- Connect to Microsoft RAS network using SSTP
+- Use HTTPS with strong encryption over port 443
+- Asynchronous HDLC frame support
+- Integration with pon/poff
+
 endef
 
 define Package/sstp-client/conffiles
-       /etc/ppp/chap-secrets
-       /etc/ppp/peers/peer-sstp-example-nopty.txt
-       /etc/ppp/peers/peer-sstp-example.txt
+/etc/ppp/chap-secrets
+/etc/ppp/peers/peer-sstp-example-nopty.txt
+/etc/ppp/peers/peer-sstp-example.txt
 endef
 
 define Package/sstp-client/install
-       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/{bin,lib}
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/.libs/sstpc $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/src/libsstp-api/.libs/*.so* $(1)/usr/lib/
        $(CP) $(PKG_BUILD_DIR)/src/pppd-plugin/.libs/*.so* $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/etc/ppp
-       $(INSTALL_DIR) $(1)/etc/peers
+
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) files/etc $(1) 
 endef
 
 $(eval $(call BuildPackage,sstp-client))