Merge pull request #19372 from cotequeiroz/libgd
[feed/packages.git] / net / strongswan / Makefile
index 641e142a05b36137560494f02cbb44084bb28ed6..711641fc8aef464c689af6a8133e9a82f49e1254 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
-PKG_VERSION:=5.9.6
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=5.9.7
+PKG_RELEASE:=$(AUTORELEASE).1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
-PKG_HASH:=91d0978ac448912759b85452d8ff0d578aafd4507aaf4f1c1719f9d0c7318ab7
+PKG_HASH:=9e64a2ba62efeac81abff1d962522404ebc6ed6c0d352a23ab7c0b2c639e3fcf
 PKG_LICENSE:=GPL-2.0-or-later
 PKG_MAINTAINER:=Philip Prindeville <philipp@redfish-solutions.com>, Noel Kuntze <noel.kuntze@thermi.consulting>
 PKG_CPE_ID:=cpe:/a:strongswan:strongswan
@@ -171,6 +171,7 @@ $(call Package/strongswan/Default)
        +strongswan-mod-des \
        +strongswan-mod-dhcp \
        +strongswan-mod-dnskey \
+       +strongswan-mod-drbg \
        +strongswan-mod-duplicheck \
        +strongswan-mod-eap-identity \
        +strongswan-mod-eap-md5 \
@@ -185,6 +186,7 @@ $(call Package/strongswan/Default)
        +strongswan-mod-gmp \
        +strongswan-mod-ha \
        +strongswan-mod-hmac \
+       +strongswan-mod-kdf \
        +strongswan-mod-kernel-netlink \
        +strongswan-mod-ldap \
        +strongswan-mod-led \
@@ -258,8 +260,10 @@ $(call Package/strongswan/Default)
        +strongswan-mod-fips-prf \
        +strongswan-mod-gmp \
        +strongswan-mod-hmac \
+       @(PACKAGE_strongswan-mod-kdf||PACKAGE_strongswan-mod-openssl||PACKAGE_strongswan-mod-wolfssl) \
        +strongswan-mod-kernel-netlink \
        +strongswan-mod-md5 \
+       +strongswan-mod-mgf1 \
        +strongswan-mod-nonce \
        +strongswan-mod-pem \
        +strongswan-mod-pgp \
@@ -296,8 +300,10 @@ $(call Package/strongswan/Default)
        +strongswan-mod-des \
        +strongswan-mod-gmpdh \
        +strongswan-mod-hmac \
+       @(PACKAGE_strongswan-mod-kdf||PACKAGE_strongswan-mod-openssl||PACKAGE_strongswan-mod-wolfssl) \
        +strongswan-mod-kernel-netlink \
        +strongswan-mod-md5 \
+       +strongswan-mod-mgf1 \
        +strongswan-mod-nonce \
        +strongswan-mod-pubkey \
        +strongswan-mod-random \
@@ -324,7 +330,9 @@ $(call Package/strongswan/Default)
        +strongswan-mod-aes \
        +strongswan-mod-gmp \
        +strongswan-mod-hmac \
+       @(PACKAGE_strongswan-mod-kdf||PACKAGE_strongswan-mod-openssl||PACKAGE_strongswan-mod-wolfssl) \
        +strongswan-mod-kernel-netlink \
+       +strongswan-mod-mgf1 \
        +strongswan-mod-nonce \
        +strongswan-mod-pubkey \
        +strongswan-mod-random \
@@ -465,6 +473,7 @@ CONFIGURE_ARGS+= \
        --disable-scripts \
        --disable-static \
        --disable-fast \
+       --enable-mgf1 \
        --enable-mediation \
        --with-systemdsystemunitdir=no \
        $(if $(CONFIG_PACKAGE_strongswan-charon-cmd),--enable-cmd,--disable-cmd) \
@@ -681,6 +690,7 @@ $(eval $(call BuildPlugin,curve25519,Curve25519 Diffie-Hellman,))
 $(eval $(call BuildPlugin,des,DES crypto,))
 $(eval $(call BuildPlugin,dhcp,DHCP based attribute provider,))
 $(eval $(call BuildPlugin,dnskey,DNS RR key decoding,))
+$(eval $(call BuildPlugin,drbg,Deterministic random bit generator,,))
 $(eval $(call BuildPlugin,duplicheck,advanced duplicate checking,))
 $(eval $(call BuildPlugin,eap-identity,EAP identity helper,))
 $(eval $(call BuildPlugin,eap-md5,EAP MD5 (CHAP) EAP auth,))
@@ -696,6 +706,7 @@ $(eval $(call BuildPlugin,gmp,libgmp,+PACKAGE_strongswan-mod-gmp:libgmp))
 $(eval $(call BuildPlugin,gmpdh,DH-Groups; no libgmp dep,))
 $(eval $(call BuildPlugin,ha,high availability cluster,))
 $(eval $(call BuildPlugin,hmac,HMAC crypto,))
+$(eval $(call BuildPlugin,kdf,KDF/PRF+,))
 $(eval $(call BuildPlugin,kernel-libipsec,libipsec kernel interface,))
 $(eval $(call BuildPlugin,kernel-netlink,netlink kernel interface,))
 $(eval $(call BuildPlugin,ldap,LDAP,+PACKAGE_strongswan-mod-ldap:libopenldap))