[pacakges] ngircd: Add berlios mirror (thanks Jonas Gorski)
[openwrt/svn-archive/archive.git] / net / subversion / Makefile
index 40202d935b4f11940df1e709429cb539b0759d27..89d8cfd714a7734aeb78ba7196e6c979f1ea1bbb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=subversion
-PKG_VERSION:=1.5.2
-PKG_RELEASE:=3
+PKG_VERSION:=1.6.9
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://subversion.tigris.org/downloads/
-PKG_MD5SUM:=8321d0e1964846090f0174cb6bb18838
+PKG_SOURCE_URL:=http://subversion.tigris.org/downloads
+PKG_MD5SUM:=9c30a47b1d48664e7afef68bb4834c53
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,9 +23,9 @@ define Package/subversion/Default
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A compelling replacement for CVS
-  DEPENDS:=+zlib +libneon +libintl +libapr +libaprutil +libpthread
+  DEPENDS:=+zlib +libneon +libintl +libaprutil
   URL:=http://subversion.tigris.org/
-  SUBMENU:=subversion
+  SUBMENU:=Version Control Systems
 endef
 
 define Package/subversion/Default/description
@@ -68,10 +68,14 @@ define Package/subversion-server/description
   This package contains the subversion server.
 endef
 
+define Package/subversion-server/conffiles
+/etc/config/subversion
+endef
+
 CONFIGURE_ARGS += \
        --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
        --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
-       --with-neon="$(STAGING_DIR)/usr/include/neon" \
+       --with-neon="$(STAGING_DIR)/usr" \
        --disable-mod-activation \
        --without-ruby-sitedir \
        --without-swig \
@@ -81,7 +85,6 @@ CONFIGURE_ARGS += \
        --with-ssl \
        --disable-neon-version-check \
        --with-apxs=no \
-       --with-apache=no \
        --without-sasl \
 
 CONFIGURE_VARS += \
@@ -109,7 +112,7 @@ define Package/subversion-server/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/svn{look,admin,dumpfilter,serve} $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/subversion.config $(1)/etc/config/subversion
+       $(INSTALL_CONF) ./files/subversion.config $(1)/etc/config/subversion
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/subversion.init $(1)/etc/init.d/subversion
 endef