fix upstream .tar.bz2 archive, remove .rej file leftover. new md5sum
[openwrt/svn-archive/archive.git] / net / subversion / Makefile
index 3d5f8dc080f97ce3d1e46bf521eff06c556df3ba..eaea22a0f1ec7f7f029641a94f02d299850210ff 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=subversion
-PKG_VERSION:=1.4.5
+PKG_VERSION:=1.5.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://subversion.tigris.org/downloads/
-PKG_MD5SUM:=4c333a5fe827568c67d195cda7a5e154
+PKG_MD5SUM:=004b57643406dd10957ec87955702189
+
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,26 +29,49 @@ define Package/subversion/Default
   SUBMENU:=subversion
 endef
 
+define Package/subversion/Default/description
+       Subversion is a free/open-source version control system. That is,
+       Subversion manages files and directories, and the changes made to them,
+       over time. This allows you to recover older versions of your data, or
+       examine the history of how your data changed. In this regard, many
+       people think of a version control system as a sort of time machine.
+endef
+
 define Package/subversion-libs
   $(call Package/subversion/Default)
   TITLE:=subversion libs
 endef
 
+define Package/subversion-libs/description
+  $(call Package/subversion/Default/description)
+  This package contains the subversion libraries.
+endef
+
 define Package/subversion-client
   $(call Package/subversion/Default)
   DEPENDS+=subversion-libs
   TITLE:=subversion client tools
 endef
 
+define Package/subversion-client/description
+  $(call Package/subversion/Default/description)
+  This package contains the subversion client tools.
+endef
+
 define Package/subversion-server
   $(call Package/subversion/Default)
   DEPENDS+=subversion-libs
   TITLE:=subversion server
 endef
 
+define Package/subversion-server/description
+  $(call Package/subversion/Default/description)
+  This package contains the subversion server.
+endef
+
 CONFIGURE_ARGS += \
-       --with-apr="$(STAGING_DIR_HOST)/bin/apr-1-config" \
-       --with-apr-util="$(STAGING_DIR_HOST)/bin/apu-1-config" \
+       --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
+       --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \
        --with-neon="$(STAGING_DIR)/usr/include/neon" \
        --disable-mod-activation \
        --without-ruby-sitedir \
@@ -66,13 +91,7 @@ CONFIGURE_VARS += \
        CPPFLAGS="-I$(STAGING_DIR)/usr/include/ -I$(STAGING_DIR)/usr/lib/libintl/include \
                -I$(STAGING_DIR)/include/" \
 
-define Build/Configure
-       $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
-endef
-
 define Build/Compile
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all local-install
 endef