[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / net / tinc / Makefile
index a4ac24dcc9f87da1017a3f58ce0e17941d870a5b..290a8a19e5b1229ce8ff8632dd1f10bc9475f316 100644 (file)
@@ -4,33 +4,37 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.7
+PKG_VERSION:=1.0.11
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
        http://ftp.yi.se/pub/tinc/ \
        http://www.mirrors.wiretapped.net/security/network-security/tinc/
-PKG_MD5SUM:=572255e6cbb9efffd9e40adb73ab7861
-PKG_CAT:=zcat
+PKG_MD5SUM:=ee0b1a3366c6e379cae34be6fa5dcb15
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS+=-std=gnu99
+
 define Package/tinc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblzo +libopenssl +zlib
+  DEPENDS:=+liblzo +libopenssl +kmod-tun
   TITLE:=VPN tunneling daemon
   URL:=http://www.tinc-vpn.org/
-  SUBMENU:=vpn
+  SUBMENU:=VPN
+endef
+
+define Package/tinc/description
+  tinc is a Virtual Private Network (VPN) daemon that uses tunnelling and
+  encryption to create a secure private network between hosts on the Internet.
 endef
 
 define Build/Configure
@@ -41,15 +45,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/tinc/install    
+define Package/tinc/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,tinc))