Update to asterisk 1.4.21 (yes there's a 1.4.21.1 but I haven't tested it)
[openwrt/svn-archive/archive.git] / net / tinc / Makefile
index cf968f484fc89167ba8aba3e4fed61e838a61447..8dc1fac2a4da3291ad809f93d41f447e31157dc5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,18 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.6
+PKG_VERSION:=1.0.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
        http://ftp.yi.se/pub/tinc/ \
        http://www.mirrors.wiretapped.net/security/network-security/tinc/
-PKG_MD5SUM:=5e636f8020d155a81c43af4ae528fda3
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=1b59583b5bc57806459c81a413fb0cc4
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,6 +26,7 @@ define Package/tinc
   DEPENDS:=+liblzo +libopenssl +zlib
   TITLE:=VPN tunneling daemon
   URL:=http://www.tinc-vpn.org/
+  SUBMENU:=VPN
 endef
 
 define Build/Configure
@@ -48,7 +45,7 @@ endef
 
 define Package/tinc/install    
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,tinc))