fix segfault and set right dependency
[openwrt/svn-archive/archive.git] / net / tinc / Makefile
index 0d29ca420a8653b2774d0b34a0ae87cc56f786ea..de4c5d8f3c9b990e83911ad15e61086b5a5fbe88 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.4
+PKG_VERSION:=1.0.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
        http://ftp.yi.se/pub/tinc/ \
        http://www.mirrors.wiretapped.net/security/network-security/tinc/
-PKG_MD5SUM:=63887373dd763f8d90cecc5a3616c363
+PKG_MD5SUM:=572255e6cbb9efffd9e40adb73ab7861
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -47,7 +47,7 @@ define Build/Compile
 endef
 
 define Package/tinc/install    
-       install -m0755 -d $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
 endef