[packages] pianobar: force the lib symlinks
[openwrt/svn-archive/archive.git] / net / tinyproxy / Makefile
index 5556af821e88cc72b4d0e7acbc187e02cbc50c55..a6b61ce0dbc4661c0e4ceb273364141d042b62ae 100644 (file)
@@ -1,57 +1,48 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
-PKG_VERSION:=1.6.3
-PKG_RELEASE:=1
+PKG_VERSION:=1.8.2
+PKG_RELEASE:=5
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/tinyproxy
-PKG_MD5SUM:=bd14d029b12621bcfd7ee71b2f4893da
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
+PKG_MD5SUM:=edc8502193cfed4974d6a770da173755
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tinyproxy
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy.
+  TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy
   URL:=http://tinyproxy.sourceforge.net/
 endef
 
 define Package/tinyproxy/conffiles
-/etc/tinyproxy/tinyproxy.conf
+/etc/config/tinyproxy
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,\
-               --enable-filter \
-               --enable-transparent-proxy \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS+= \
+       --enable-filter \
+       --enable-transparent \
+       --disable-regexcheck \
 
 define Package/tinyproxy/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tinyproxy $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/share/tinyproxy
        $(CP) $(PKG_INSTALL_DIR)/usr/share/tinyproxy/*.html $(1)/usr/share/tinyproxy/
-       $(INSTALL_DIR) $(1)/etc/tinyproxy
-       $(CP) $(PKG_INSTALL_DIR)/etc/tinyproxy/tinyproxy.conf $(1)/etc/tinyproxy/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/tinyproxy.config $(1)/etc/config/tinyproxy
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/tinyproxy.init $(1)/etc/init.d/tinyproxy
 endef