[packages] openswan: add a patch to fix build on 2.6.30 targets where CONFIG_COMPAT_N...
[openwrt/svn-archive/archive.git] / net / tmsnc / Makefile
index f4b822f666632597e49801b53309ff961b29a0fd..b7b25fc8d56899814545e15b854da0b7745a4a9f 100644 (file)
@@ -4,20 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tmsnc
-PKG_VERSION:=0.3.1
+PKG_VERSION:=0.3.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/tmsnc
-PKG_MD5SUM:=3b30e5dab0b1b679d2b945c3a5713636
+PKG_MD5SUM:=337dae91d4775e03b6681f61db56d2a7
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -43,13 +41,7 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/tmsnc/install   
+define Package/tmsnc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tmsnc $(1)/usr/bin/
 endef