[packages] tor: update to 0.2.1.30, add missing librt dependency after r25548, use...
[openwrt/svn-archive/archive.git] / net / tor / Makefile
index cb510273b182c38f66f915e5e8494c481e421042..d505035a3b582f64bd635568a495b6123dbcb1a8 100644 (file)
@@ -1,39 +1,51 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
-PKG_VERSION:=0.2.0.26-rc
+PKG_VERSION:=0.2.1.30
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.torproject.org/dist/
-PKG_MD5SUM:=aa1179fab4dc69a10278e70729681053
+PKG_SOURCE_URL:=https://www.torproject.org/dist \
+       https://archive.torproject.org/tor-package-archive
+PKG_MD5SUM:=6c6d61e053af5969a245d025c4cfce9d
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/tor
+define Package/tor/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent +libopenssl +libpthread +zlib
-  TITLE:=An anonymous Internet communication system
-  URL:=http://tor.eff.org/
+  URL:=https://www.torproject.org/
 endef
 
-define Package/tor/description
- Tor is a toolset for a wide range of organizations and people that want to 
- improve their safety and security on the Internet. Using Tor can help you 
- anonymize web browsing and publishing, instant messaging, IRC, SSH, and 
- more. Tor also provides a platform on which software developers can build 
+define Package/tor/Default/description
+ Tor is a toolset for a wide range of organizations and people that want to
+ improve their safety and security on the Internet. Using Tor can help you
+ anonymize web browsing and publishing, instant messaging, IRC, SSH, and
+ more. Tor also provides a platform on which software developers can build
  new applications with built-in anonymity, safety, and privacy features.
 endef
 
+define Package/tor
+$(call Package/tor/Default)
+  TITLE:=An anonymous Internet communication system
+  DEPENDS:=+libevent +libopenssl +libpthread +librt
+endef
+
+define Package/tor-geoip
+$(call Package/tor/Default)
+  TITLE:=GeoIP db for tor
+  DEPENDS:=+tor
+endef
+
 define Package/tor/conffiles
 /etc/tor/torrc
 endef
@@ -68,7 +80,7 @@ if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
 fi
 
 if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $name to /etc/passwd"
+        echo "adding user $$name to /etc/passwd"
         echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
 endef
@@ -81,20 +93,22 @@ CONFIGURE_VARS += \
        CROSS_COMPILE="yes" \
 
 # pass CFLAGS again to override -O2 set by configure
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
 
 define Package/tor/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/or/tor $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
        $(INSTALL_DIR) $(1)/etc/tor
-       $(INSTALL_DATA) ./files/torrc $(1)/etc/tor/torrc
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
+endef
+
+define Package/tor-geoip/install
+       $(INSTALL_DIR) $(1)/usr/share/tor
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/tor/geoip $(1)/usr/share/tor/
 endef
 
 $(eval $(call BuildPackage,tor))
+$(eval $(call BuildPackage,tor-geoip))