Unbound: Update scripts to build conf file from UCI
[feed/packages.git] / net / unbound / Makefile
index 62367f758fb70ec4aa0fa3e0770fe785097614bd..eb82db766fe82575bcb434b5d7bc25416a5da22f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unbound
 PKG_VERSION:=1.5.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
@@ -120,6 +120,7 @@ CONFIGURE_ARGS += \
        --with-user=unbound
 
 define Package/unbound/conffiles
+/etc/config/unbound
 /etc/unbound/unbound.conf
 endef
 
@@ -141,13 +142,19 @@ define Package/unbound/install
                $(PKG_INSTALL_DIR)/etc/unbound/unbound.conf \
                $(1)/etc/unbound/unbound.conf
        $(INSTALL_DATA) ./files/root.key $(1)/etc/unbound/root.key
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/unbound.uci $(1)/etc/config/unbound
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_BIN) ./files/unbound.iface $(1)/etc/hotplug.d/iface/25-unbound
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/ntp
+       $(INSTALL_BIN) ./files/unbound.ntpd $(1)/etc/hotplug.d/ntp/25-unbound
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/unbound.init $(1)/etc/init.d/unbound
        $(INSTALL_DIR) $(1)/usr/lib/unbound
-       $(INSTALL_DATA) ./files/unbound.sh $(1)/usr/lib/unbound/unbound.sh
+       $(INSTALL_DATA) ./files/dnsmasq.sh $(1)/usr/lib/unbound/dnsmasq.sh
+       $(INSTALL_DATA) ./files/iptools.sh $(1)/usr/lib/unbound/iptools.sh
        $(INSTALL_DATA) ./files/rootzone.sh $(1)/usr/lib/unbound/rootzone.sh
+       $(INSTALL_DATA) ./files/unbound.sh $(1)/usr/lib/unbound/unbound.sh
 endef
 
 define Package/unbound-anchor/install