[packages] net-snmp: don't autoreconf
[openwrt/svn-archive/archive.git] / net / updatedd / Makefile
index ae439261035e6be67776052dce78e9fc5f8e86b0..d106c8b272492e682dbe2957e5e280da40f951e1 100644 (file)
@@ -1,21 +1,23 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=updatedd
 PKG_VERSION:=2.6
-PKG_RELEASE:=5
+PKG_RELEASE:=7
 
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.bz2
 PKG_MD5SUM:=f03446105ed043cd5dbd1ab95484d27f
 
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/updatedd
@@ -23,7 +25,7 @@ define Package/updatedd
   CATEGORY:=Network
   MENU:=1
   TITLE:=A tool to update dynamic dns services
-  URL:=http://www.philipp-benner.de/updatedd/
+  URL:=http://savannah.nongnu.org/projects/updatedd/
 endef
 
 define Package/updatedd/description
@@ -33,6 +35,10 @@ Updatedd is a small tool that will update one of many dynamic
 
 endef
 
+define Package/updatedd/conffiles
+/etc/config/updatedd
+endef
+
 define Package/updatedd-mod-changeip
   SECTION:=net
   CATEGORY:=Network
@@ -103,9 +109,10 @@ define Package/updatedd-mod-zoneedit
   TITLE:=zoneedit.com
 endef
 
-MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake )
+       $(call Build/Configure/Default)
+endef
 
 define BuildPlugin
   define Package/$(1)/install