nuke the nstx init script. it is unusable and needs a rewrite
[openwrt/svn-archive/archive.git] / net / vncrepeater / Makefile
index ead836f3813b5a601fdb3cdb236ca06b23ac8018..b47a265799a521ee3e3deb33586483bd5cc1c098 100644 (file)
@@ -4,21 +4,20 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vncrepeater
 PKG_VERSION:=0.12
 PKG_RELEASE:=1
-PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
 
-PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/openwrt/packages/vncrepeater/src
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/openwrt/packages/vncrepeater/src
+PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,12 +26,13 @@ define Package/vncrepeater
   CATEGORY:=Network
   DEPENDS:=+uclibcxx
   TITLE:=UltraVNC repeater for Linux
-  DESCRIPTION:=Viewer can be behind Nat router or directly connected to the internet\\\
-  Instead of forwarding serveral ports, you only need to forward 1 port\\\
-  If the PC that runs the Repeater has access to the local DNS server,\\\
-  you can use your local DNS names instead of 10.10.10.12.\\\
-  This could be handy when you have a dynamic DHCP server allocating\\\
-  ip adresses for your PC.\\\
+  DESCRIPTION:=\
+       Viewer can be behind Nat router or directly connected to the internet \\\
+       Instead of forwarding serveral ports, you only need to forward 1 port \\\
+       If the PC that runs the Repeater has access to the local DNS server, \\\
+       you can use your local DNS names instead of 10.10.10.12.\\\
+       This could be handy when you have a dynamic DHCP server allocating \\\
+       ip adresses for your PC.
   URL:=http://ultravnc.sourceforge.net/addons/repeater.html
 endef
 
@@ -41,19 +41,18 @@ define Package/vncrepeater/
 endef
 
 define Build/Compile
-$(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               repeater)
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
+               STAGING_DIR="$(STAGING_DIR)" \
+               repeater \
+       )
 endef
 
 define Package/vncrepeater/install     
-       install -d -m0755 $(1)/usr/sbin $(1)/etc
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc
        $(CP) $(PKG_BUILD_DIR)/repeater $(1)/usr/sbin/$(PKG_NAME)
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_BUILD_DIR)/uvncrepeater.ini $(1)/etc/vncrepeater.conf
-       install -d -m0755 $(1)/etc/init.d
-       $(CP) $(PKG_BUILD_DIR)/S60vncrepeater $(1)/etc/init.d/
 endef
 
 $(eval $(call BuildPackage,vncrepeater))