[patchteam] upgrade mosquitto MQTT tools from 0.13 to 0.14.4 - Signed-off-by: Karl...
[openwrt/svn-archive/archive.git] / net / vsftpd / Makefile
index 051281bc597af5a879b4bfe69dfdf5a6c139b1fe..32cae30a4adcce93a41fc336c163f3f4ed3d55b7 100644 (file)
@@ -1,41 +1,49 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vsftpd
-PKG_VERSION:=2.0.5
-PKG_RELEASE:=2
+PKG_VERSION:=2.3.4
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
-PKG_MD5SUM:=146062e8b2f93af43ff6c2c770feea94
+PKG_SOURCE_URL:=https://security.appspot.com/downloads/
+PKG_MD5SUM:=2ea5d19978710527bb7444d93b67767a
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vsftpd
+  SUBMENU:=File Transfer
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A fast and secure FTP server
   URL:=http://vsftpd.beasts.org/
+  MAINTAINER:=Cezary Jackiewicz <cezary@eko.one.pl>
 endef
 
 define Package/vsftpd/conffiles
 /etc/vsftpd.conf
 endef
 
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               vsftpd
+endef
+
 define Package/vsftpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/vsftpd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) ./files/vsftpd.conf $(1)/etc/vsftpd.conf
+       $(INSTALL_CONF) ./files/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME).conf
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/vsftpd.init $(1)/etc/init.d/vsftpd
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,vsftpd))