[curl]: upgrade to 7.33.0, add myself as maintainer
[openwrt/svn-archive/archive.git] / net / vtun / Makefile
index 6fb7a5ee2f90f4cc2fb88a7a376e0a7cecb00783..e8d4422d687d2aadbecdf78e295fb055be90e0d9 100644 (file)
@@ -8,46 +8,67 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vtun
-PKG_VERSION:=3.0.1
+PKG_VERSION:=3.0.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/vtun
-PKG_MD5SUM:=c342ffe77055d4248a38f0b380f28c1b
+PKG_MD5SUM:=d3d8bc4d58886498a1c338670eab9315
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vtun
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+kmod-tun +liblzo +libopenssl +zlib
+  DEPENDS:=+kmod-tun +VTUN_LZO:liblzo +VTUN_LZO:zlib +VTUN_SSL:libopenssl
   TITLE:=VPN tunneling daemon
   URL:=http://vtun.sourceforge.net
   SUBMENU:=VPN
+  MENU:=1
+endef
+
+define Package/vtun/config
+menu "Configuration"
+        depends on PACKAGE_vtun
+
+config VTUN_config
+       bool
+
+       depends on PACKAGE_vtun
+       config VTUN_LZO
+               bool "enable vtun compression"
+               help
+                       vtun tunnels will be compressed
+               default y
+
+       config VTUN_SSL
+               bool "enable vtun ssl encryption"
+               help
+                       vtun tunnels will be encrypted
+               default y
+endmenu
 endef
 
 define Package/vtun/conffiles
 /etc/vtund.conf
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-lzo-headers="$(STAGING_DIR)/usr/include/lzo" \
-               --with-lzo-lib="$(STAGING_DIR)/usr/lib/" \
-               --with-ssl-headers="$(STAGING_DIR)/usr/include/openssl" \
-               , \
-               LIBS="$(TARGET_LDFLAGS)" \
-               BLOWFISH_HDR_DIR="$(STAGING_DIR)/usr/include/openssl" \
-               LZO_HDR_DIR="$(STAGING_DIR)/usr/include/lzo" \
-               SSL_HDR_DIR="$(STAGING_DIR)/usr/include/openssl" \
-       )
-endef
+CONFIGURE_ARGS += \
+       $(if $(CONFIG_VTUN_LZO),--with-lzo-lib="$(STAGING_DIR)/usr/lib/",--disable-zlib) \
+       $(if $(CONFIG_VTUN_LZO),--with-lzo-headers="$(STAGING_DIR)/usr/include/lzo",--disable-lzo) \
+       $(if $(CONFIG_VTUN_SSL),--with-ssl-headers="$(STAGING_DIR)/usr/lib/",--disable-ssl) \
+
+CONFIGURE_VARS += \
+       LIBS="$(TARGET_LDFLAGS)" \
+       $(if $(CONFIG_VTUN_LZO),LZO_HDR_DIR="$(STAGING_DIR)/usr/include/lzo") \
+       $(if $(CONFIG_VTUN_SSL),BLOWFISH_HDR_DIR="$(STAGING_DIR)/usr/include/openssl") \
+       $(if $(CONFIG_VTUN_SSL),SSL_HDR_DIR="$(STAGING_DIR)/usr/include/openssl") \
 
-define Build/Compile   
+define Build/Compile
        $(call Build/Compile/Default,vtund)
 endef
 
-define Package/vtun/install    
+define Package/vtun/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/vtund.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/sbin