batman: switch to a more recent trunk version, which fixes the build for 2.6.26....
[openwrt/svn-archive/archive.git] / net / wget / Makefile
index 01e0e34e0c3efa265d43f162507183ff0f960c9e..7811ac2a85574bf1137144160db2ed817922168d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wget
-PKG_VERSION:=1.10.2
-PKG_RELEASE:=2
+PKG_VERSION:=1.11.4
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=795fefbb7099f93e2d346b026785c4b8
+PKG_MD5SUM:=f5076a8c2ec2b7f334cb6e3059820f9c
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,13 +26,12 @@ define Package/wget/Default
 endef
 
 define Package/wget/Default/description
-       Wget is a network utility to retrieve files from the Web
-       using http and ftp, the two most widely used Internet
-       protocols. It works non-interactively, so it will work in
-       the background, after having logged off. The program supports
-       recursive retrieval of web-authoring pages as well as ftp
-       sites -- you can use wget to make mirrors of archives and
-       home pages or to travel the Web like a WWW robot.
+ Wget is a network utility to retrieve files from the Web using http 
+ and ftp, the two most widely used Internet    protocols. It works 
+ non-interactively, so it will work in the background, after having 
+ logged off. The program supports recursive retrieval of web-authoring 
+ pages as well as ftp sites -- you can use wget to make mirrors of 
+ archives and home pages or to travel the Web like a WWW robot.
 endef
 
 define Package/wget
@@ -75,7 +74,7 @@ endef
 
 # FIXME: check if busybox really provides a wget applet
 define Package/wget/postrm
-!/bin/sh
+#!/bin/sh
 ln -sf ../../bin/busybox $${IPKG_INSTROOT}/usr/bin/wget
 endef
 
@@ -86,19 +85,19 @@ CONFIGURE_ARGS += \
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_wget),)
   define Build/with-ssl
-    $(call Build/Template,wget,with-ssl, \
-       --with-ssl \
-       --with-libssl-prefix="$(STAGING_DIR)/usr" \
-    )
+       $(call Build/Template,wget,with-ssl, \
+               --with-ssl \
+               --with-libssl-prefix="$(STAGING_DIR)/usr" \
+       )
   endef
 endif
 $(eval $(Build/with-ssl))
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_wget-nossl),)
   define Build/without-ssl
-    $(call Build/Template,wget-nossl,without-ssl, \
-       --without-ssl \
-    )  
+       $(call Build/Template,wget-nossl,without-ssl, \
+               --without-ssl \
+       )
   endef
 endif
 $(eval $(Build/without-ssl))