[packages] ddns-scripts: use /proc/uptime as time reference, this makes it immune...
[openwrt/svn-archive/archive.git] / net / wrt-radauth / Makefile
index 89b58643581336941f44617fee5594e95da00f5c..57b578144fc168eb6df61888712b0f10f544cd7c 100644 (file)
@@ -4,18 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wrt-radauth
-PKG_VERSION:=1.0
+PKG_VERSION:=0.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=f941e3139175dc6b87f6c89ba8848a07
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.zerfleddert.de/wrt54g/
-PKG_SOURCE:=$(PKG_NAME).tar.gz
-PKG_CAT:=zcat
+PKG_MD5SUM:=1713b96a157f9e209cf7986f38ef57d9
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
@@ -24,24 +22,29 @@ include $(INCLUDE_DIR)/package.mk
 define Package/wrt-radauth
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=kmod-brcm-wl +nvram
+  DEPENDS:=+kmod-brcm-wl +nvram
   TITLE:=A Radius MAC authenticator for Broadcom based access points
-  DESCRIPTION:=This software watches the stations associating to a broadcom based\\\
-  AccessPoint (e.g. Linksys WRT54G) and sends an authentication request\\\
-  to the radius-server specified in nvram.\\\
   URL:=http://www.zerfleddert.de/wrt54g/
 endef
+
+define Package/wrt-radauth/description
+       This software watches the stations associating to a broadcom based 
+       AccessPoint (e.g. Linksys WRT54G) and sends an authentication request 
+       to the radius-server specified in nvram.
+endef
   
 define Build/Compile
-$(call Build/Compile/Default,CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib")
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       $(call Build/Compile/Default, \
+               CFLAGS="$(EXTRA_CFLAGS)" \
+               LDFLAGS="$(EXTRA_LDFLAGS)" \
+       )
 endef
 
 define Package/wrt-radauth/install     
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/radius-client $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/wrt-radauth $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/radius-client $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wrt-radauth $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,wrt-radauth))