zerotier: update to 1.14.0
[feed/packages.git] / net / zerotier / patches / 0002-remove-PIE-options.patch
index 0b21991eb9864ce8d4177242c01c0b7a2c20bbc9..4e44f2ef4523ac588e1a7f49dfbd1879a40175a5 100644 (file)
@@ -1,6 +1,6 @@
-From 9b97099560a79529f2b5a748e73164ae038d2b76 Mon Sep 17 00:00:00 2001
+From c10b5ed4c6c44e36178b0a5a82da9e8eaa957008 Mon Sep 17 00:00:00 2001
 From: Moritz Warning <moritzwarning@web.de>
-Date: Sun, 27 Aug 2023 23:27:33 +0200
+Date: Mon, 6 May 2024 22:34:15 +0200
 Subject: [PATCH 2/5] remove PIE options
 
 Signed-off-by: Moritz Warning <moritzwarning@web.de>
@@ -10,16 +10,16 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
 
 --- a/make-linux.mk
 +++ b/make-linux.mk
-@@ -70,7 +70,7 @@ else
+@@ -71,7 +71,7 @@ else
        override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
        CXXFLAGS?=-O3 -fstack-protector
        override CXXFLAGS+=-Wall -Wno-deprecated -std=c++17 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
 -      LDFLAGS=-pie -Wl,-z,relro,-z,now
 +      LDFLAGS=-Wl,-z,relro,-z,now
-       RUSTFLAGS=--release
+       ZT_CARGO_FLAGS=--release
  endif
  
-@@ -327,7 +327,7 @@ ifeq ($(ZT_CONTROLLER),1)
+@@ -333,7 +333,7 @@ ifeq ($(ZT_CONTROLLER),1)
  endif
  
  # ARM32 hell -- use conservative CFLAGS
@@ -28,7 +28,7 @@ Signed-off-by: Moritz Warning <moritzwarning@web.de>
        ifeq ($(shell if [ -e /usr/bin/dpkg ]; then dpkg --print-architecture; fi),armel)
                override CFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
                override CXXFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
-@@ -354,8 +354,8 @@ ifeq ($(ZT_USE_ARM32_NEON_ASM_CRYPTO),1)
+@@ -360,8 +360,8 @@ ifeq ($(ZT_USE_ARM32_NEON_ASM_CRYPTO),1)
  endif
  
  # Position Independence