luci-app-olsrd2: New Package for OLSR2 configuration and status visualisation'
[feed/routing.git] / nodogsplash / Makefile
index ea167594e71bc35fd4e6f1b8b3d21e488bdc3a91..1c8a8f7306e8bbcdc9ebca8d396b27671a131a4b 100644 (file)
@@ -6,38 +6,38 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
-PKG_FIXUP:=autoreconf
-PKG_VERSION:=3.3.2
+PKG_VERSION:=5.0.0
 PKG_RELEASE:=1
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/nodogsplash/nodogsplash/tar.gz/v$(PKG_VERSION)?
-PKG_SOURCE:=nodogsplash-$(PKG_VERSION).tar.gz
-PKG_HASH:=5a7b14dd2cce6a8ca261a720d87948565fc2f05d4926bf155b9e0db483ff6bcb
-PKG_BUILD_DIR:=$(BUILD_DIR)/nodogsplash-$(PKG_VERSION)
+PKG_HASH:=a7665f4a42997746a31e9217f2f54e360aa7fc4bc72bd89faa08f1ccf7875b5e
 
 PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
 PKG_BUILD_PARALLEL:=1
-PKG_LICENSE:=GPL-2.0+
 
 include $(INCLUDE_DIR)/package.mk
 
-
 define Package/nodogsplash
-       SUBMENU:=Captive Portals
-       SECTION:=net
-       CATEGORY:=Network
-       DEPENDS:=+libpthread +iptables-mod-ipopt +libmicrohttpd-no-ssl
-       TITLE:=Open public network gateway daemon
-       URL:=https://github.com/nodogsplash/nodogsplash
-       CONFLICTS:=nodogsplash2
+  SUBMENU:=Captive Portals
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpthread +iptables-mod-ipopt +libmicrohttpd-no-ssl
+  TITLE:=Open public network gateway daemon
+  URL:=https://github.com/nodogsplash/nodogsplash
+  CONFLICTS:=nodogsplash2
 endef
 
 define Package/nodogsplash/description
-       Nodogsplash is a Captive Portal that offers a simple way to
-       provide restricted access to the Internet by showing a splash
-       page to the user before Internet access is granted.
-       It also incorporates an API that allows the creation of
-       sophisticated authentication applications.
+  Nodogsplash is a Captive Portal that offers a simple way to
+  provide restricted access to the Internet by showing a splash
+  page to the user before Internet access is granted.
+  It also incorporates an API that allows the creation of
+  sophisticated authentication applications.
 endef
 
 define Package/nodogsplash/install
@@ -59,7 +59,6 @@ define Package/nodogsplash/install
        $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/etc/init.d/nodogsplash $(1)/etc/init.d/
        $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/etc/uci-defaults/40_nodogsplash $(1)/etc/uci-defaults/
        $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/usr/lib/nodogsplash/restart.sh $(1)/usr/lib/nodogsplash/
-       $(CP) $(PKG_BUILD_DIR)/forward_authentication_service/PreAuth/demo-preauth.sh $(1)/usr/lib/nodogsplash/login.sh
 endef
 
 define Package/nodogsplash/postrm