prevent verbose script from corrupting .pkginfo
[openwrt/staging/mkresin.git] / openwrt / include / verbose.mk
index 1ef403ccfb95a1bce23da75a178621bdf1722874..6d7c7ef6c16fd01f9b9a3413c494dced13114704 100644 (file)
@@ -2,17 +2,12 @@
 # $Id:$
 
 ifndef KBUILD_VERBOSE
-  ifeq ($(DUMP),)
-    KBUILD_VERBOSE=0
-  else
-    KBUILD_VERBOSE=99
-  endif
+  KBUILD_VERBOSE=0
   ifeq ("$(origin V)", "command line")
     KBUILD_VERBOSE=$(V)
   endif
 endif
 
-
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
@@ -23,6 +18,7 @@ ifneq ($(KBUILD_VERBOSE),99)
        }
   else
     export QUIET:=1
+    NO_TRACE_MAKE:=$(MAKE) V=99
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif