.pkginfo cleanup #2
[openwrt/staging/wigyori.git] / openwrt / package / base-files / Makefile
index bb20894096017cbad1dc7c78177200431886f88a..f81c681c2649e2c86dee0601a559bed880a21045 100644 (file)
@@ -1,7 +1,7 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
 PKG_RELEASE:=8
@@ -12,12 +12,15 @@ ifeq ($(REV),)
 REV:=0
 endif
 
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
 
 ifneq ($(DUMP),1)
 TARGET:=-$(BOARD)-$(KERNEL)
 UCLIBC_VERSION:=${shell cat $(STAGING_DIR)/uclibc_version}
 LIBGCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version}
+else
+UCLIBC_VERSION:=<UCLIBC_VERSION>
+LIBGCC_VERSION:=<LIBGCC_VERSION>
 endif
 
 CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)