update to latest upstream release
[openwrt/svn-archive/archive.git] / openwrt / package / lighttpd / Makefile
index 65a8d35141bcbb5727e4289f5144d44681748757..97fa3610add3820bea0a8199e6bd37e5a6bdb4d7 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.8
+PKG_VERSION:=1.4.9
 PKG_RELEASE:=1
-PKG_MD5SUM:=7d7790ef95ff5755f73bfcda4f13696d
+PKG_MD5SUM:=20a171774a0615069de3704db52483aa
 
 PKG_SOURCE_URL:=http://www.lighttpd.net/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -31,6 +31,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_ACCESSLOG,lighttpd-mod-accesslog,$(PKG_V
 $(eval $(call PKG_template,LIGHTTPD_MOD_ALIAS,lighttpd-mod-alias,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_AUTH,lighttpd-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_CGI,lighttpd-mod-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_EVASIVE,lighttpd-mod-evasive,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_EXPIRE,lighttpd-mod-expire,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_FASTCGI,lighttpd-mod-fastcgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_PROXY,lighttpd-mod-proxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -46,6 +47,7 @@ $(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_AUTH,auth))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_CGI,cgi))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_EVASIVE,evasive))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_EXPIRE,expire))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_FASTCGI,fastcgi))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_PROXY,proxy))
@@ -120,10 +122,10 @@ $(IPKG_LIGHTTPD):
        install -m0755 ./files/lighttpd.init $(IDIR_LIGHTTPD)/etc/init.d/lighttpd
        install -m0755 -d $(IDIR_LIGHTTPD)/usr/lib/lighttpd
        for m in dirlisting indexfile staticfile; do \
-               cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lighttpd/mod_$$m.so $(IDIR_LIGHTTPD)/usr/lib/lighttpd/ ; \
+               $(CP) $(PKG_INSTALL_DIR)/usr/lib/lighttpd/mod_$$m.so $(IDIR_LIGHTTPD)/usr/lib/lighttpd/ ; \
        done
        install -m0755 -d $(IDIR_LIGHTTPD)/usr/sbin
-       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/lighttpd $(IDIR_LIGHTTPD)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lighttpd $(IDIR_LIGHTTPD)/usr/sbin/
        $(RSTRIP) $(IDIR_LIGHTTPD)
        $(IPKG_BUILD) $(IDIR_LIGHTTPD) $(PACKAGE_DIR)