store stamp file for 'development headers installed' in the staging dir instead of...
[openwrt/staging/dedeckeh.git] / openwrt / package / rules.mk
index 26b41969d9df57ec360a4c3f5baab6b1aad64339..1fd6f2a8ab7abcfa5012d538249bbac88daf37cf 100644 (file)
@@ -6,11 +6,11 @@ endif
 
 define Build/DefaultTargets
   ifeq ($(DUMP),)
-    ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . | tee /tmp/xy1),.)
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
       $(PKG_BUILD_DIR)/.prepared: package-clean
     endif
 
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/xy2),$(IPKG_$(1)))
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
       $(PKG_BUILD_DIR)/.built: package-rebuild
     endif
   endif
@@ -28,14 +28,19 @@ define Build/DefaultTargets
   $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(call Build/Compile)
        touch $$@
-    
-  $(PKG_BUILD_DIR)/.dev-installed: $(PKG_BUILD_DIR)/.built
+
+  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
        $(call Build/InstallDev)
        touch $$@
-    
+       
+  ifdef Build/InstallDev
+    compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
+  endif
+
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
+       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
   package-rebuild: FORCE
        @-rm $(PKG_BUILD_DIR)/.built
@@ -51,7 +56,15 @@ define Package/Default
   DEPENDS:=
   MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
   SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
-  VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+  ifneq ($(PKG_VERSION),)
+    ifneq ($(PKG_RELEASE),)
+      VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+    else
+      VERSION:=$(PKG_VERSION)
+    endif
+  else
+    VERSION:=$(PKG_RELEASE)
+  endif
   PKGARCH:=$(ARCH)
   PRIORITY:=optional
   DEFAULT:=
@@ -134,8 +147,7 @@ define BuildPackage
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
        ( \
                DEPENDS=; \
-               for depend in $$(IDEPEND_$(1)); do \
-                       [ "$$$${depend%%%%%%%%[A-Za-z]*}" = "@" ] && continue; \
+               for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
                        DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
                done; \
                echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
@@ -229,12 +241,11 @@ endef
 
 define Build/Compile/Default
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                CC=$(TARGET_CC) \
                CROSS="$(TARGET_CROSS)" \
-               PREFIX="$$(IDIR_$(1))" \
-               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include" \
                ARCH="$(ARCH)" \
-               DESTDIR="$$(IDIR_$(1))" \
                $(1);
 endef
 
@@ -242,16 +253,10 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
-define Build/InstallDev
-endef
-
 define Build/Clean
        $(MAKE) clean
 endef
 
-define Build/UninstallDev
-endef
-
 ifneq ($(DUMP),)
   dumpinfo: FORCE
        @$(DUMPINFO)
@@ -264,7 +269,7 @@ else
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured
 
-  compile-targets: $(PKG_BUILD_DIR)/.dev-installed
+  compile-targets:
   compile: compile-targets
 
   install-targets: