Merged ipt_time to 2.6 kernel and added ipt_time for all 2.4 archs, closes #185
[openwrt/svn-archive/archive.git] / openwrt / target / linux / rules.mk
index be151ea10f5ba7e94a3e89dc173e95741f21b33e..758b5251321e7401e1263d7ea4aa81b1b43ce60c 100644 (file)
@@ -1,5 +1,6 @@
 LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
        -e 's/mipsel/mips/' \
+       -e 's/mipseb/mips/' \
        -e 's/powerpc/ppc/' \
        -e 's/sh[234]/sh/' \
 )
@@ -17,11 +18,7 @@ else
 KDEPEND_$(1):=$($(4))
 endif
 
-ifeq ($$(strip $(5)),)
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE))
-else
-IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE)), $(5)
-endif
+IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)) $(foreach pkg,$(5),", $(pkg)")
 
 PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk
 I_$(1) := $(PKG_BUILD_DIR)/ipkg/$(2)