add support for interfaces with ipv6, but no ipv4 (patch from #2695)
[openwrt/svn-archive/archive.git] / package / alsa / Makefile
index 8aa80e74a5c75f6781ed094eeae68ca2e466562e..8dc7b871a494f132bbe99794bad75dfef10aab4f 100644 (file)
@@ -16,9 +16,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
 PKG_MD5SUM:=4cff99be4b225e96663fbd61cabe3182
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +23,6 @@ define KernelPackage/alsa
   SUBMENU:=Other modules
   DEPENDS:=@USB_SUPPORT @LINUX_2_4
   TITLE:=Advanced Linux Sound Architecture
-  DESCRIPTION:=
   FILES:=$(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD=$(call AutoLoad,70,$(shell cat ./files/alsa.modules))
 endef
@@ -46,21 +42,19 @@ ifeq ($(LINUX_KARCH),mips)
   KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
 endif
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               CFLAGS="$(KERNEL_C_INCS)" \
-               ./configure \
-                       --with-build="$(LINUX_DIR)" \
-                       --with-kernel="$(LINUX_DIR)" \
-                       --with-cross="$(KERNEL_CROSS)" \
-                       --with-redhat=no \
-                       --with-suse=no \
-                       --with-oss=yes \
-                       --with-isapnp=no \
-                       --with-sequencer=no \
-                       --with-cards=usb-audio \
-       );
-endef
+CONFIGURE_VARS:= \
+       CFLAGS="$(KERNEL_C_INCS)"
+
+CONFIGURE_ARGS:= \
+       --with-build="$(LINUX_DIR)" \
+       --with-kernel="$(LINUX_DIR)" \
+       --with-cross="$(KERNEL_CROSS)" \
+       --with-redhat=no \
+       --with-suse=no \
+       --with-oss=yes \
+       --with-isapnp=no \
+       --with-sequencer=no \
+       --with-cards=usb-audio
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \