install readelf to STAGING_DIR_HOST (eglibc requires it, not all systems have it)
[openwrt/svn-archive/archive.git] / package / ar7-atm / Makefile
index c42895d59c6bdcf6f81ac595a50c51a89b651631..8700bd12dff821fe420fb827da6e17b231b1945e 100644 (file)
@@ -10,29 +10,39 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=sangam_atm
-PKG_VERSION:=07.02.01.00
-PKG_RELEASE:=1
+PKG_VERSION:=D7.03.01.00
+PKG_RELEASE:=R2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=dc4d5c36532503a2f234f3303a0bf563
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.bz2
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_MD5SUM:=bc6e9c6adb1be25820c7ee661de8ca7d
 
 include $(INCLUDE_DIR)/package.mk
 
-define KernelPackage/sangam-atm-annex-a
+define KernelPackage/sangam-atm/Default
   SUBMENU:=Network Devices
-  DEPENDS:=@LINUX_2_6_AR7 +kmod-atm 
-  TITLE:=AR7 ADSL driver (Annex A, ADSL over POTS)
-  DESCRIPTION:=The AR7 ADSL driver for Annex A (ADSL over POTS)
-  VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
+  DEPENDS:=@TARGET_ar7 +kmod-atm 
+  TITLE:=AR7 ADSL driver
   FILES:=$(PKG_BUILD_DIR)/tiatm.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,tiatm)
 endef
 
+define KernelPackage/sangam-atm-annex-a
+$(call KernelPackage/sangam-atm/Default)
+  TITLE+= (Annex A, ADSL over POTS)
+endef
+
+define KernelPackage/sangam-atm-annex-a/description
+ The AR7 ADSL driver for Annex A (ADSL over POTS).
+endef
+
 define KernelPackage/sangam-atm-annex-b
-  $(call KernelPackage/sangam-atm-annex-a)
-  TITLE:=AR7 ADSL driver (Annex B, ADSL over ISDN)
-  DESCRIPTION:=The AR7 ADSL driver for Annex B (ADSL over ISDN)
+$(call KernelPackage/sangam-atm/Default)
+  TITLE+= (Annex B, ADSL over ISDN)
+endef
+
+define KernelPackage/sangam-atm-annex-b/description
+ The AR7 ADSL driver for Annex B (ADSL over ISDN).
 endef
 
 define Build/Compile