base-files: procd init is now the default, remove files.old
[openwrt/svn-archive/archive.git] / package / base-files / Makefile
index 5bb2e25652f0ea132932e1c2e14cd95d1b29b3a7..3635a564781700408f8509b5b3ca8a4ab33e461b 100644 (file)
@@ -11,10 +11,11 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=124
+PKG_RELEASE:=141
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
+PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -55,6 +56,12 @@ define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
+define Package/base-files/config
+config PROCD_INIT
+       bool "Use procd as the init process"
+       default n
+endef
+
 ifneq ($(CONFIG_PREINITOPT),)
 define ImageConfigOptions
        mkdir -p $(1)/lib/preinit