kexec-tools: add patch to fix issue with appended DTB and zImage on ARM
[openwrt/staging/ynezz.git] / package / boot / kexec-tools / Makefile
index 1c686a254008162f8fc889542ddc3d7adb984f8d..0fbbefdc3b9f3b08aa9267d6fe22132993335175 100644 (file)
@@ -8,14 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kexec-tools
-PKG_VERSION:=2.0.14
-PKG_RELEASE:=1
+PKG_VERSION:=2.0.21
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kexec
-PKG_HASH:=ffb2e7e99d9d08754c6bc1922aed3c000094f318665d82a72ecc76c4ff1c0dc6
-
-PKG_FIXUP:=autoreconf
+PKG_HASH:=e113142dee891638ad96e0f72cf9277b244477619470b30c41999d312e8e8702
 
 PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB CONFIG_KEXEC_LZMA
 
@@ -25,7 +23,6 @@ define Package/kexec-tools/Default
   SECTION:=utils
   CATEGORY:=Utilities
   URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
-  MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 endef
 
 define Package/kexec-tools
@@ -44,7 +41,7 @@ define Package/kexec
   $(call Package/kexec-tools/Default)
   TITLE:=Kernel boots kernel
   DEPENDS:=\
-       @armeb||@arm||@i386||@x86_64||@powerpc64||@mipsel||@mips \
+       @(armeb||arm||i386||x86_64||powerpc64||mipsel||mips) \
        +KEXEC_ZLIB:zlib +KEXEC_LZMA:liblzma @KERNEL_KEXEC
 endef
 
@@ -52,17 +49,6 @@ define Package/kexec/description
  The kexec utility allows to load and boot another kernel.
 endef
 
-define Package/kdump
-  $(call Package/kexec-tools/Default)
-  TITLE:=Kernel crash analysis
-  DEPENDS:=+kexec @i386||@x86_64||@arm @KERNEL_CRASH_DUMP
-endef
-
-define Package/kdump/description
- The kdump package allows to automatically boot into a
- special kernel for analyzing kernel crashes using kdump.
-endef
-
 define Package/kexec/config
        source "$(SOURCE)/Config.in"
 endef
@@ -109,28 +95,5 @@ define Package/kexec/install
        $(LN) ../usr/sbin/kexec $(1)/sbin/kexec
 endef
 
-define Package/kdump/install
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config $(1)/etc/uci-defaults
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kdump $(PKG_INSTALL_DIR)/usr/sbin/vmcore-dmesg $(1)/usr/sbin
-       $(INSTALL_BIN) ./files/kdump.init $(1)/etc/init.d/kdump
-       $(INSTALL_BIN) ./files/kdump.defaults $(1)/etc/uci-defaults/kdump
-       $(INSTALL_CONF) ./files/kdump.config $(1)/etc/config/kdump
-endef
-
-define Package/kdump/prerm
-#!/bin/sh
-
-case $$(uname -m) in
-       i?86|x86_64)
-               if grep -q " crashkernel=" /boot/grub/grub.cfg; then
-                       mount /boot -o remount,rw
-                       sed -i 's/ crashkernel=[^ ]*//' /boot/grub/grub.cfg
-                       mount /boot -o remount,ro
-               fi
-               ;;
-esac
-endef
-
 $(eval $(call BuildPackage,kexec-tools))
 $(eval $(call BuildPackage,kexec))
-$(eval $(call BuildPackage,kdump))