kexec-tools: add patch to fix issue with appended DTB and zImage on ARM
[openwrt/staging/ynezz.git] / package / boot / kexec-tools / Makefile
index 8c1c255cbabce2cba867e58a1f36cb786da37571..0fbbefdc3b9f3b08aa9267d6fe22132993335175 100644 (file)
@@ -8,39 +8,52 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kexec-tools
-PKG_VERSION:=2.0.4
-PKG_RELEASE:=1
+PKG_VERSION:=2.0.21
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kexec
-PKG_MD5SUM:=05992bc8c0673fc55be7b6d27e48a8db
+PKG_HASH:=e113142dee891638ad96e0f72cf9277b244477619470b30c41999d312e8e8702
 
-PKG_FIXUP:=autoreconf
-
-PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB
+PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB CONFIG_KEXEC_LZMA
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/kexec-tools
+define Package/kexec-tools/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@armeb||@arm||@i386||@powerpc64||@mipsel||@mips +KEXEC_ZLIB:zlib
-  TITLE:=Kernel boots kernel
   URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
-  MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-  MENU:=1
+endef
+
+define Package/kexec-tools
+  $(call Package/kexec-tools/Default)
+  TITLE:=kexec-tools transition meta package
+  DEPENDS:=+kexec
 endef
 
 define Package/kexec-tools/description
- kexec is a set of systems call that allows you to load
+ kexec is a set of system calls that allows you to load
  another kernel from the currently executing Linux kernel.
+ The kexec utility allows to load and boot another kernel.
+endef
+
+define Package/kexec
+  $(call Package/kexec-tools/Default)
+  TITLE:=Kernel boots kernel
+  DEPENDS:=\
+       @(armeb||arm||i386||x86_64||powerpc64||mipsel||mips) \
+       +KEXEC_ZLIB:zlib +KEXEC_LZMA:liblzma @KERNEL_KEXEC
+endef
+
+define Package/kexec/description
+ The kexec utility allows to load and boot another kernel.
 endef
 
-define Package/kexec-tools/config
+define Package/kexec/config
        source "$(SOURCE)/Config.in"
 endef
 
-KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
+KEXEC_TARGET_NAME:=$(ARCH)-linux-$(TARGET_SUFFIX)
 
 CONFIGURE_ARGS = \
                --target=$(KEXEC_TARGET_NAME) \
@@ -55,7 +68,8 @@ CONFIGURE_ARGS = \
                --libexecdir=/usr/lib \
                --sysconfdir=/etc \
                $(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib \
-               --without-lzma
+               $(if $(CONFIG_KEXEC_LZMA),--with,--without)-lzma \
+               TARGET_LD="$(TARGET_CROSS)ld"
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
@@ -64,24 +78,22 @@ CONFIGURE_VARS += \
        BUILD_CC="$(HOSTCC)" \
        TARGET_CC="$(TARGET_CC)"
 
-kexec-extra-sbin-$(CONFIG_KEXEC_TOOLS_kdump) += kdump
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Package/kexec-tools/install
+       :
+endef
+
+define Package/kexec/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) \
-               $(addprefix $(PKG_INSTALL_DIR)/usr/sbin/, \
-                       $(kexec-extra-sbin-y)) \
-               $(kexec-extra-bin-y) \
-               $(PKG_INSTALL_DIR)/usr/sbin/kexec \
-               $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kexec $(1)/usr/sbin
 
 # make a link for compatability with other distros
        $(INSTALL_DIR) $(1)/sbin
-       ln -s /usr/sbin/kexec $(1)/sbin/kexec
+       $(LN) ../usr/sbin/kexec $(1)/sbin/kexec
 endef
 
 $(eval $(call BuildPackage,kexec-tools))
+$(eval $(call BuildPackage,kexec))