uboot-at91: Add support for SAMA5D4 Xplained board
[openwrt/staging/dedeckeh.git] / package / boot / uboot-at91 / Makefile
index 6a806ff635f1907f3ae1c8a19f2274dc045784aa..8dc5e3ea3de97dfae800418e4f4ce493c066e5bc 100644 (file)
@@ -17,21 +17,71 @@ include $(INCLUDE_DIR)/package.mk
 
 define U-Boot/Default
   BUILD_TARGET:=at91
-  BUILD_SUBTARGET:=legacy
   UBOOT_IMAGE:=u-boot.bin boot.bin
 endef
 
 define U-Boot/at91sam9m10g45ek_nandflash
   NAME:=AT91SAM9M10G45-EK board (NandFlash)
+  BUILD_SUBTARGET:=legacy
 endef
 
 define U-Boot/at91sam9x5ek_nandflash
   NAME:=AT91SAM9X5-EK board (NandFlash)
+  BUILD_SUBTARGET:=legacy
+endef
+
+define uboot/sama5d3_xplained_nandflash
+  TITLE:=U-Boot for the SAMA5D3 Xplained board (NandFlash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
+define uboot/sama5d3_xplained_mmc
+  TITLE:=U-Boot for the SAMA5D3 Xplained board (SDcard)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
+define uboot/sama5d2_xplained_spiflash
+  TITLE:=U-Boot for the SAMA5D2 Xplained board (SPI Flash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d2_xplained
+endef
+
+define uboot/sama5d2_xplained_mmc
+  TITLE:=U-Boot for the SAMA5D2 Xplained board (SDcard/EMMC)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d2_xplained
+endef
+
+define uboot/sama5d4_xplained_spiflash
+  TITLE:=U-Boot for the SAMA5D4 Xplained board (SPI Flash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d4_xplained
+endef
+
+define uboot/sama5d4_xplained_mmc
+  TITLE:=U-Boot for the SAMA5D4 Xplained board (SDcard)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d4_xplained
+endef
+
+define uboot/sama5d4_xplained_nandflash
+  TITLE:=U-Boot for the SAMA5D4 Xplained board (NandFlash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
 UBOOT_TARGETS := \
        at91sam9m10g45ek_nandflash \
-       at91sam9x5ek_nandflash
+       at91sam9x5ek_nandflash \
+    sama5d3_xplained_nandflash \
+    sama5d3_xplained_mmc \
+    sama5d2_xplained_mmc \
+    sama5d2_xplained_spiflash \
+    sama5d4_xplained_mmc \
+    sama5d4_xplained_spiflash \
+    sama5d4_xplained_nandflash
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \