uboot-envtools: bump PKG_RELEASE
[openwrt/staging/nbd.git] / package / boot / uboot-envtools / Makefile
index 1c6b7897161404d299011946a643e4e9762e6f1b..9647b38385308ff5a795a77d0adbb674214de084 100644 (file)
@@ -9,16 +9,17 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
-PKG_VERSION:=2019.07
-PKG_RELEASE:=2
+PKG_VERSION:=2023.07.02
+PKG_RELEASE:=3
 
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+    https://ftp.denx.de/pub/u-boot \
+    https://mirror.cyberbits.eu/u-boot \
+    ftp://ftp.denx.de/pub/u-boot
+PKG_HASH:=6b6a48581c14abb0f95bd87c1af4d740922406d7b801002a9f94727fdde021d5
 PKG_SOURCE_SUBDIR:=$(PKG_DISTNAME)-$(PKG_VERSION)
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_DISTNAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=https://git.denx.de/u-boot.git
-PKG_SOURCE_VERSION:=e5aee22e4be75e75a854ab64503fc80598bc2004
-PKG_MIRROR_HASH:=58c1ecaf901b6bf65c5e872b5449b642694ae5acebf61f91f0d4bc20b4c654b7
 
 PKG_BUILD_DEPENDS:=fstools
 
@@ -44,34 +45,42 @@ define Package/uboot-envtools/description
 endef
 
 define Build/Configure
-       touch $(PKG_BUILD_DIR)/include/config.h
-       mkdir -p $(PKG_BUILD_DIR)/include/config
-       touch $(PKG_BUILD_DIR)/include/config/auto.conf
-       mkdir -p $(PKG_BUILD_DIR)/include/generated
-       touch $(PKG_BUILD_DIR)/include/generated/autoconf.h
+       $(call Build/Compile/Default,tools-only_defconfig)
 endef
 
+define Build/Compile
+       $(call Build/Compile/Default,envtools)
+endef
+
+# We need to override the ARCH passed by buildsystem as otherwise the defconfig
+# for tools-only wont match and the includes for sandbox will be dropped
 MAKE_FLAGS += \
+       ARCH="sandbox" \
        TARGET_CFLAGS="$(TARGET_CFLAGS)" \
-       TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
-       no-dot-config-targets=envtools \
-       envtools
+       TARGET_LDFLAGS="$(TARGET_LDFLAGS)"
 
 define Package/uboot-envtools/conffiles
 /etc/config/ubootenv
 /etc/fw_env.config
+/etc/fw_sys.config
 endef
 
 define Package/uboot-envtools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/env/fw_printenv $(1)/usr/sbin
        $(LN) fw_printenv $(1)/usr/sbin/fw_setenv
+       $(INSTALL_BIN) ./files/fw_printsys $(1)/usr/sbin
+       $(INSTALL_BIN) ./files/fw_setsys $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/lib
        $(INSTALL_DATA) ./files/uboot-envtools.sh $(1)/lib
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(if $(wildcard ./files/$(BOARD)), \
-               $(INSTALL_DATA) ./files/$(BOARD) \
-               $(1)/etc/uci-defaults/30_uboot-envtools \
+       $(if $(wildcard ./files/$(BOARD)_$(SUBTARGET)), \
+               $(INSTALL_DATA) ./files/$(BOARD)_$(SUBTARGET) \
+               $(1)/etc/uci-defaults/30_uboot-envtools, \
+               $(if $(wildcard ./files/$(BOARD)), \
+                       $(INSTALL_DATA) ./files/$(BOARD) \
+                       $(1)/etc/uci-defaults/30_uboot-envtools \
+               ) \
        )
 endef