uboot-envtools: rename 'imx6' to 'imx'
[openwrt/staging/nbd.git] / package / boot / uboot-imx6 / Makefile
index 25d68bf6ca434718b38544ad63067e5f6b6cc2d2..6c2297dd815d15d05d12d75821b2f1b8aedc07a4 100644 (file)
@@ -7,10 +7,10 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=2019.01
-PKG_RELEASE:=1
+PKG_VERSION:=2020.04
+PKG_RELEASE:=$(AUTORELEASE)
 
-PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
+PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -20,56 +20,28 @@ define U-Boot/Default
   UBOOT_IMAGE:=u-boot.imx
 endef
 
-define U-Boot/mx6cuboxi
-   NAME:=SolidRun Cubox-i boards
-   UBOOT_IMAGE:=SPL u-boot.img
-   UBOOT_MAKE_FLAGS:=SPL u-boot.img
-   BUILD_DEVICES:=cubox-i
-   HIDDEN:=1
-endef
-
-define U-Boot/mx6sabresd
-  NAME:=SABRE i.MX6Quad board
-endef
-
-define U-Boot/nitrogen6dl
-  NAME:=Nitrogen6x i.MX6Dual-Lite 1GB board
-endef
-
-define U-Boot/nitrogen6dl2g
-  NAME:=Nitrogen6x i.MX6Dual-Lite 2GB board
+define U-Boot/apalis_imx6
+  NAME:=Toradex Apalis
+  UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
+  UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+  BUILD_DEVICES:=toradex_apalis
 endef
 
-define U-Boot/nitrogen6q
-  NAME:=Nitrogen6x/SABRE Lite (MX6Q/1GB)
-endef
-
-define U-Boot/nitrogen6q2g
-  NAME:=Nitrogen6x i.MX6Quad 2GB board
-endef
-
-define U-Boot/nitrogen6s
-  NAME:=Nitrogen6x i.MX6Solo 512MB board
-endef
-
-define U-Boot/nitrogen6s1g
-  NAME:=Nitrogen6x i.MX6Solo 1GB board
+define U-Boot/mx6cuboxi
+  NAME:=SolidRun Cubox-i boards
+  UBOOT_IMAGE:=SPL u-boot.img
+  UBOOT_MAKE_FLAGS:=SPL u-boot.img
+  BUILD_DEVICES:=solidrun_cubox-i
 endef
 
 define U-Boot/wandboard
   NAME:=Wandboard Dual Lite/Quad/Solo
-  BUILD_DEVICES:=wandboard
+  BUILD_DEVICES:=wandboard_dual
 endef
 
 UBOOT_TARGETS := \
+       apalis_imx6 \
        mx6cuboxi \
-       mx6sabresd \
-       nitrogen6dl \
-       nitrogen6dl2g \
-       nitrogen6q \
-       nitrogen6q2g \
-       nitrogen6s \
-       nitrogen6s1g \
        wandboard
 
 UBOOT_MAKE_FLAGS += u-boot.imx