uboot-kirkwood: add support for Zyxel NSA310S
[openwrt/staging/wigyori.git] / package / boot / uboot-kirkwood / Makefile
index 4ce1485a134dcece15f05e41a1eec12e67977460..d2cbc1041b0ec601ca41111e4103e6e969054334 100644 (file)
@@ -7,10 +7,10 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=2019.01
+PKG_VERSION:=2020.04
 PKG_RELEASE:=1
 
-PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
+PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -59,6 +59,11 @@ define U-Boot/nsa310
   BUILD_DEVICES:=zyxel_nsa310b
 endef
 
+define U-Boot/nsa310s
+  NAME:=Zyxel NSA310S
+  BUILD_DEVICES:=zyxel_nsa310s
+endef
+
 define U-Boot/nsa325
   NAME:=Zyxel NSA325v1 and v2
   BUILD_DEVICES:=zyxel_nsa325
@@ -85,6 +90,7 @@ UBOOT_TARGETS := \
        ib62x0 ib62x0_second_stage \
        iconnect iconnect_second_stage \
        nsa310 \
+       nsa310s \
        nsa325 \
        pogo_e02 pogo_e02_second_stage \
        pogoplugv4