uboot-mediatek: update to 2021.10
[openwrt/staging/hauke.git] / package / boot / uboot-mediatek / Makefile
index 37af42e66424963ee939a75d755881b1b56c5c85..a5801afa2d37a071b2d1c06b6388dd7948e94659 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2021.04
-PKG_HASH:=0d438b1bb5cceb57a18ea2de4a0d51f7be5b05b98717df05938636e0aadfe11a
+PKG_VERSION:=2021.10
+PKG_HASH:=cde723e19262e646f2670d25e5ec4b1b368490de950d4e26275a988c36df0bd4
 PKG_BUILD_DEPENDS:=arm-trusted-firmware-tools/host
 
 include $(INCLUDE_DIR)/u-boot.mk
@@ -120,6 +120,11 @@ define Build/fip-image
                $(PKG_BUILD_DIR)/u-boot.fip
 endef
 
+define Build/Configure
+       $(call Build/Configure/U-Boot)
+       sed -i 's/CONFIG_TOOLS_LIBCRYPTO=y/# CONFIG_TOOLS_LIBCRYPTO is not set/' $(PKG_BUILD_DIR)/.config
+endef
+
 define Build/Compile
        $(call Build/Compile/U-Boot)
 ifeq ($(UBOOT_IMAGE),u-boot.fip))