gdb: Update to version 10.1
[openwrt/staging/ldir.git] / package / devel / gdb / patches / 110-shared_libgcc.patch
index f07ac8ca24ba37dc634a01e5761d1ff61eb713d7..de92a1f945cbbd29d490eed5ed195562192d7a14 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1283,13 +1283,13 @@ if test -z "$LD"; then
+@@ -1302,13 +1302,13 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -17,7 +17,7 @@
    AC_LANG_PUSH(C++)
    AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1629,7 +1629,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1648,7 +1648,7 @@ AC_ARG_WITH(stage1-ldflags,
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -26,7 +26,7 @@
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1658,7 +1658,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1677,7 +1677,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
  
 --- a/configure
 +++ b/configure
-@@ -5053,14 +5053,14 @@ if test -z "$LD"; then
+@@ -5075,14 +5075,14 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -56,7 +56,7 @@
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -5861,7 +5861,7 @@ else
+@@ -5883,7 +5883,7 @@ else
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
   fi
  fi
  
-@@ -5897,7 +5897,7 @@ else
+@@ -5919,7 +5919,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then