treewide: drop librt and libpthread packages
[openwrt/staging/jow.git] / package / devel / perf / Makefile
index b77e29a666782da23d159c330f35f71bd9d84ea4..c7c02146cc40f75d08781442f6d6c5d38ea3eabe 100644 (file)
@@ -10,16 +10,25 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=perf
 PKG_VERSION:=$(LINUX_VERSION)
-PKG_RELEASE:=2
+PKG_RELEASE:=5
 
-PKG_USE_MIPS16:=0
+PKG_BUILD_FLAGS:=no-mips16 no-lto
+PKG_BUILD_PARALLEL:=1
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_FLAGS:=nonshared
+
+# Perf's makefile and headers are not relocatable and must be built from the
+# Linux sources directory
+PKG_BUILD_DIR:=$(LINUX_DIR)/tools/perf-$(TARGET_DIR_NAME)
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
+  DEPENDS:= +libelf +libdw +PACKAGE_libunwind:libunwind +objdump @!IN_SDK @KERNEL_PERF_EVENTS \
+           +PACKAGE_libbfd:libbfd +PACKAGE_libopcodes:libopcodes
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org
@@ -29,39 +38,44 @@ define Package/perf/description
   perf is the Linux performance monitoring tool
 endef
 
-# Perf's makefile and headers are not relocatable and must be built from the
-# Linux sources directory
-define Build/Prepare
-       $(RM) -r $(PKG_BUILD_DIR)
-       $(LN) $(LINUX_DIR)/tools/perf $(PKG_BUILD_DIR)
-endef
+HOST_CFLAGS += -I$(LINUX_DIR)/tools/include
 
-# MAKE_FLAGS should be passed again upon cleaning because Perf's makefile
-# always performs checks before processing any rule
-define Build/Clean
-       -$(MAKE) -C $(PKG_BUILD_DIR) \
-               NO_DWARF=1 \
-               $(MAKE_FLAGS) \
-               clean
-endef
+TARGET_LDFLAGS += $(INTL_LDFLAGS)
 
 MAKE_FLAGS = \
        ARCH="$(LINUX_KARCH)" \
        NO_LIBPERL=1 \
        NO_LIBPYTHON=1 \
        NO_NEWT=1 \
+       NO_LZMA=1 \
+       NO_BACKTRACE=1 \
+       NO_LIBNUMA=1 \
+       NO_GTK2=1 \
+       NO_LIBAUDIT=1 \
+       NO_LIBCRYPTO=1 \
+       NO_LIBUNWIND=1 \
+       NO_LIBZSTD=1 \
+       NO_LIBCAP=1 \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        CC="$(TARGET_CC)" \
        LD="$(TARGET_CROSS)ld" \
-       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+       EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
+       KBUILD_HOSTCFLAGS="$(HOST_CFLAGS)" \
+       $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
        WERROR=0 \
-       V=1 \
+       O=$(PKG_BUILD_DIR) \
        prefix=/usr
 
+define Build/Compile
+       +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
+               --no-print-directory \
+               -C $(LINUX_DIR)/tools/perf
+endef
+
 define Package/perf/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(LINUX_DIR)/tools/perf/perf $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/perf $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,perf))