new upstream release 2.51 with some fixes, see http://www.thekelleys.org.uk/dnsmasq...
[openwrt/staging/florian.git] / package / dnsmasq / Makefile
index 3444efefff043c7a8d888e98cfeda1d682c791c4..27f438c738577d5b462bc2b3a726bbe13fb58924 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.49
+PKG_VERSION:=2.51
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=7ccc861d8a733474f9c0a0a127006ee9
+PKG_MD5SUM:=97465261a6de5258a3c3edfe51ca16a4
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,6 +30,7 @@ endef
 
 define Package/dnsmasq/conffiles
 /etc/config/dhcp
+/etc/dnsmasq.conf
 endef
 
 define Build/Compile
@@ -46,6 +47,7 @@ define Package/dnsmasq/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef