port the mbsd_multi patch to gcc 4.4.0, refresh the other patches
[openwrt/staging/florian.git] / package / grub / Makefile
index 98bb68b564714be2ab1eeeed9f39be608a1512d5..e828ec0338c0d02b676828ab59aa1d3d2e92e480 100644 (file)
@@ -1,10 +1,9 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4855 2006-09-24 20:49:31Z nico $
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -22,6 +21,8 @@ PKG_TARGETS:=bin
 
 include $(INCLUDE_DIR)/package.mk
 
+export grub_cv_prog_objcopy_absolute=yes
+
 define Package/grub
   SECTION:=boot
   DEPENDS:=@TARGET_x86
@@ -30,7 +31,13 @@ define Package/grub
   URL:=http://www.gnu.org/software/grub/
 endef
 
-ifeq ($(HOST_ARCH),x86_64)
+ifeq ($(HOST_OS),Linux)
+  NATIVEGRUB-i386:=1
+  NATIVEGRUB-i686:=1
+  NATIVEGRUB:=$(NATIVEGRUB-$(HOST_ARCH))
+endif
+
+ifeq ($(NATIVEGRUB),)
 CONFIGURE_FLAGS:= \
        --target=$(GNU_TARGET_NAME) \
        --host=$(GNU_TARGET_NAME) \
@@ -39,6 +46,7 @@ else
 CONFIGURE_FLAGS:=
 endif
 
+ifneq ($(HOST_OS),Darwin)
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
                LDFLAGS="-static" \
@@ -62,7 +70,7 @@ define Build/Configure
 endef
 
 #
-# ./configure detects whether the host compiler supports 
+# ./configure detects whether the host compiler supports
 # -fno-stack-protector but only sets STAGE2_CFLAGS accordingly
 #
 define Build/Compile
@@ -77,5 +85,6 @@ define Build/InstallDev
                install
        mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
 endef
+endif
 
 $(eval $(call BuildPackage,grub))