port the mbsd_multi patch to gcc 4.4.0, refresh the other patches
[openwrt/staging/florian.git] / package / grub / Makefile
index 9fc98173f59c42695593675eb03daa6cbe73a3bd..e828ec0338c0d02b676828ab59aa1d3d2e92e480 100644 (file)
@@ -1,10 +1,9 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4855 2006-09-24 20:49:31Z nico $
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -16,13 +15,14 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://alpha.gnu.org/gnu/grub
 PKG_MD5SUM:=cd3f3eb54446be6003156158d51f4884
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/grub-$(PKG_VERSION)
 PKG_TARGETS:=bin
 
 include $(INCLUDE_DIR)/package.mk
 
+export grub_cv_prog_objcopy_absolute=yes
+
 define Package/grub
   SECTION:=boot
   DEPENDS:=@TARGET_x86
@@ -31,7 +31,13 @@ define Package/grub
   URL:=http://www.gnu.org/software/grub/
 endef
 
-ifeq ($(HOST_ARCH),x86_64)
+ifeq ($(HOST_OS),Linux)
+  NATIVEGRUB-i386:=1
+  NATIVEGRUB-i686:=1
+  NATIVEGRUB:=$(NATIVEGRUB-$(HOST_ARCH))
+endif
+
+ifeq ($(NATIVEGRUB),)
 CONFIGURE_FLAGS:= \
        --target=$(GNU_TARGET_NAME) \
        --host=$(GNU_TARGET_NAME) \
@@ -40,6 +46,7 @@ else
 CONFIGURE_FLAGS:=
 endif
 
+ifneq ($(HOST_OS),Darwin)
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
                LDFLAGS="-static" \
@@ -63,7 +70,7 @@ define Build/Configure
 endef
 
 #
-# ./configure detects whether the host compiler supports 
+# ./configure detects whether the host compiler supports
 # -fno-stack-protector but only sets STAGE2_CFLAGS accordingly
 #
 define Build/Compile
@@ -78,5 +85,6 @@ define Build/InstallDev
                install
        mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
 endef
+endif
 
 $(eval $(call BuildPackage,grub))