[backfire] target: standardize config file & patches dir names (2.6)
[openwrt/svn-archive/archive.git] / package / hostap-driver / Makefile
index 3a170f6b00b0592c0bc026e17872c98921ed14b2..3ea3a25e22586fa38a256a9a94113d3ae04d460e 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -46,8 +45,8 @@ endef
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP support for Prism2/2.5/3
-  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211 +wireless-tools
-  KCONFIG:=CONFIG_HOSTAP
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +LINUX_2_6:kmod-lib80211 +wireless-tools
+  KCONFIG:=CONFIG_HOSTAP CONFIG_HOSTAP_FIRMWARE=y CONFIG_HOSTAP_FIRMWARE_NVRAM=y
 endef
 
 define KernelPackage/hostap/2.4
@@ -80,7 +79,7 @@ endef
 define KernelPackage/hostap-cs
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PCMCIA adaptors
-  DEPENDS:=@PCMCIA_SUPPORT kmod-hostap +kmod-pcmcia-core
+  DEPENDS:=@PCMCIA_SUPPORT +kmod-hostap +kmod-pcmcia-core
   KCONFIG:=CONFIG_HOSTAP_CS
   AUTOLOAD:=$(call AutoLoad,60,hostap_cs)
 endef
@@ -104,7 +103,7 @@ endef
 define KernelPackage/hostap-pci
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PCI adaptors
-  DEPENDS:=@PCI_SUPPORT kmod-hostap
+  DEPENDS:=@PCI_SUPPORT +kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PCI
   AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
 endef
@@ -130,7 +129,7 @@ endef
 define KernelPackage/hostap-plx
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PLX9052 based PCI adaptors
-  DEPENDS:=@PCI_SUPPORT kmod-hostap
+  DEPENDS:=@PCI_SUPPORT +kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PLX
   AUTOLOAD:=$(call AutoLoad,60,hostap_plx)
 endef
@@ -174,12 +173,7 @@ else
   endef
 endif
 
-define KernelPackage/hostap-pci/install
-       $(INSTALL_DIR) $(1)/lib/wifi
-       $(INSTALL_DATA) ./files/lib/wifi/hostap.sh $(1)/lib/wifi
-endef
-
-define KernelPackage/hostap-plx/install
+define KernelPackage/hostap/install
        $(INSTALL_DIR) $(1)/lib/wifi
        $(INSTALL_DATA) ./files/lib/wifi/hostap.sh $(1)/lib/wifi
 endef