hostapd: remove unnecessary dependency on mac80211
[openwrt/staging/chunkeey.git] / package / hostapd / Makefile
index 9f93054db7177dc9072195b0b51427d65c07c2ed..774d08e13f0b566249df24d5fc2e02bc84430786 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_VERSION:=20110527
-PKG_RELEASE:=2
-PKG_REV:=ceb34f250af7a7082f18c1e0451dc7fbc0f000f3
+PKG_VERSION:=20111103
+PKG_RELEASE:=3
+PKG_REV:=6caaae1e48da247b21b54ea6001646597e35d9b1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
-PKG_MIRROR_MD5SUM:=4b98902d782813b41aca1faff613f677
+PKG_MIRROR_MD5SUM:=2650d83c1d4649a5df9fe265f8a5775f
 
 PKG_BUILD_DEPENDS:= \
        PACKAGE_kmod-madwifi:madwifi \
-       PACKAGE_kmod-mac80211:mac80211 \
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK \
@@ -218,7 +217,6 @@ TARGET_CPPFLAGS := \
        -I$(PKG_BUILD_DIR)/src/crypto \
        $(TARGET_CPPFLAGS) \
        -I$(STAGING_DIR)/usr/include/madwifi \
-       -I$(STAGING_DIR)/usr/include/mac80211 \
        -DCONFIG_LIBNL20 \
        -D_GNU_SOURCE