mac80211: include the kfifo backport in compat.ko if necessary (fixes libertas, rt2x00)
[openwrt/svn-archive/archive.git] / package / iproute2 / patches / 000-debian_patches_3.patch
index 68954f66570c577cc2f40c2567a845e7ba63a96f..8e688f89ccc75f97b4cfd7a411bfd4e3519e66c4 100644 (file)
@@ -1,3 +1,15 @@
+---
+ Makefile                  |    4 
+ doc/Makefile              |    8 
+ doc/ip-cref.tex           |   16 +
+ include/linux/pkt_sched.h |  518 ++++++++++++++++++++++++++++++++++++++++++++++
+ ip/iptunnel.c             |    2 
+ misc/Makefile             |    3 
+ tc/Makefile               |    1 
+ tc/q_htb.c                |  308 +++++++++++++++++++++++++++
+ tc/q_wrr.c                |  322 ++++++++++++++++++++++++++++
+ 9 files changed, 1177 insertions(+), 5 deletions(-)
+
 --- a/doc/ip-cref.tex
 +++ b/doc/ip-cref.tex
 @@ -1307,6 +1307,19 @@ peers are allowed to send to us.
@@ -20,7 +32,7 @@
  
  \item \verb|advmss NUMBER|
  
-@@ -2666,6 +2679,9 @@ http://www.cisco.com/univercd/cc/td/doc/
+@@ -2665,6 +2678,9 @@ http://www.cisco.com/univercd/cc/td/doc/
  \bibitem{RFC2414}  M.~Allman, S.~Floyd, C.~Partridge.
  ``Increasing TCP's Initial Window'', RFC-2414.
  
  #ifndef __LINUX_PKT_SCHED_H
  #define __LINUX_PKT_SCHED_H
  
-@@ -518,4 +924,116 @@ struct tc_drr_stats
+@@ -481,4 +887,116 @@ struct tc_drr_stats {
        __u32   deficit;
  };
  
  #endif
 --- a/ip/iptunnel.c
 +++ b/ip/iptunnel.c
-@@ -129,7 +129,7 @@ static int parse_args(int argc, char **a
+@@ -130,7 +130,7 @@ static int parse_args(int argc, char **a
                        NEXT_ARG();
                        p->o_flags |= GRE_KEY;
                        if (strchr(*argv, '.'))