mac80211: include the kfifo backport in compat.ko if necessary (fixes libertas, rt2x00)
[openwrt/svn-archive/archive.git] / package / iproute2 / patches / 006-iproute2-tc_esfq.patch
index d0347549dd26f6e14e6b43ecfd51af0c8806a8c9..65dbc4f55609a4437727787534b278aa3d9ec8a7 100644 (file)
@@ -1,7 +1,12 @@
-diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iproute2-2.6.11-050330/include/linux/pkt_sched.h
---- iproute2-2.6.11-050330/include/linux/pkt_sched.h   2007-05-04 22:21:48.000000000 -0400
-+++ iproute2-2.6.11-050330/include/linux/pkt_sched.h   2007-05-04 22:27:12.000000000 -0400
-@@ -174,8 +174,38 @@
+---
+ include/linux/pkt_sched.h |   59 +++++++++++++
+ tc/Makefile               |    1 
+ tc/q_esfq.c               |  200 ++++++++++++++++++++++++++++++++++++++++++++++
+ 3 files changed, 260 insertions(+)
+
+--- a/include/linux/pkt_sched.h
++++ b/include/linux/pkt_sched.h
+@@ -174,8 +174,38 @@ struct tc_sfq_qopt
   *
   *    The only reason for this is efficiency, it is possible
   *    to change these parameters in compile time.
@@ -40,7 +45,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iprout
  /* RED section */
  
  enum
-@@ -551,8 +580,37 @@
+@@ -579,8 +609,37 @@ struct tc_sfq_xstats {
   *
   *    The only reason for this is efficiency, it is possible
   *    to change these parameters in compile time.
@@ -77,11 +82,10 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/include/linux/pkt_sched.h iprout
 +
  /* RED section */
  
- enum
-diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/Makefile iproute2-2.6.11-050330/tc/Makefile
---- iproute2-2.6.11-050330/tc/Makefile 2007-05-04 22:21:48.000000000 -0400
-+++ iproute2-2.6.11-050330/tc/Makefile 2007-05-04 22:27:37.000000000 -0400
-@@ -6,6 +6,7 @@
+ enum {
+--- a/tc/Makefile
++++ b/tc/Makefile
+@@ -8,6 +8,7 @@ SHARED_LIBS ?= y
  TCMODULES :=
  TCMODULES += q_fifo.o
  TCMODULES += q_sfq.o
@@ -89,9 +93,8 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/Makefile iproute2-2.6.11-0503
  TCMODULES += q_red.o
  TCMODULES += q_prio.o
  TCMODULES += q_tbf.o
-diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-050330/tc/q_esfq.c
---- iproute2-2.6.11-050330/tc/q_esfq.c 1969-12-31 19:00:00.000000000 -0500
-+++ iproute2-2.6.11-050330/tc/q_esfq.c 2007-05-04 22:37:54.000000000 -0400
+--- /dev/null
++++ b/tc/q_esfq.c
 @@ -0,0 +1,200 @@
 +/*
 + * q_esfq.c           ESFQ.
@@ -114,7 +117,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-0503
 +#include <unistd.h>
 +#include <syslog.h>
 +#include <fcntl.h>
-+#include <math.h> 
++#include <math.h>
 +#include <sys/socket.h>
 +#include <netinet/in.h>
 +#include <arpa/inet.h>
@@ -140,7 +143,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-0503
 +      memset(&opt, 0, sizeof(opt));
 +
 +      opt.hash_kind= TCA_SFQ_HASH_CLASSIC;
-+      
++
 +      while (argc > 0) {
 +              if (strcmp(*argv, "quantum") == 0) {
 +                      NEXT_ARG();
@@ -186,7 +189,7 @@ diff -urN --exclude=.svn iproute2-2.6.11-050330/tc/q_esfq.c iproute2-2.6.11-0503
 +                      NEXT_ARG();
 +                      if(strcmp(*argv, "classic") == 0) {
 +                              opt.hash_kind= TCA_SFQ_HASH_CLASSIC;
-+                      } else 
++                      } else
 +                      if(strcmp(*argv, "dst") == 0) {
 +                              opt.hash_kind= TCA_SFQ_HASH_DST;
 +                      } else