package/kernel/linux: only access kernel config if DUMP is unset
[openwrt/staging/yousong.git] / package / kernel / linux / Makefile
index 21381c7296e4644f74b5299674ed69512c3e908c..7f38f3e6e263c7faf37a48e1615cf1fd79b1e83c 100644 (file)
@@ -23,9 +23,8 @@ export SHELL:=/bin/sh
 
 include $(INCLUDE_DIR)/package.mk
 
-STAMP_BUILT:=$(STAMP_BUILT)_$(firstword $(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | md5sum))
-
 ifeq ($(DUMP),)
+  STAMP_BUILT:=$(STAMP_BUILT)_$(firstword $(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | md5sum))
   -include $(LINUX_DIR)/.config
 endif