kmod-regmap: enable MMIO support
[openwrt/svn-archive/archive.git] / package / kernel / linux / modules / 001-depends.mk
index e0af73570516822a658d60b21d8e7acd487eab31..806c3dcfd5da6d4b5b396fbabd35839ceb93762e 100644 (file)
@@ -5,33 +5,10 @@
 # See /LICENSE for more information.
 #
 
-define AddDepends/crc16
-  DEPENDS+= +kmod-lib-crc16 $(1)
-endef
-
-define AddDepends/hid
-  DEPENDS+= +kmod-hid $(1)
-endef
-
-define AddDepends/input
-  DEPENDS+= +kmod-input-core $(1)
-endef
-
-
 define AddDepends/nls
   DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
 endef
 
-
-define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx)
-endef
-
 define AddDepends/rfkill
-  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
-endef
-
-
-define AddDepends/rtc
-  DEPENDS+= @RTC_SUPPORT
+  DEPENDS+= +USE_RFKILL:kmod-rfkill $(1)
 endef