oxnas: move target-specific modules into target's modules.mk
[openwrt/staging/lynxis.git] / package / kernel / linux / modules / block.mk
index 88cdcc5786e2e932e6a64845213ec5a01c76aa70..0c8d9b1fe9253426919e1f70feb2c320ce7c5a46 100644 (file)
@@ -151,22 +151,6 @@ endef
 $(eval $(call KernelPackage,ata-nvidia-sata))
 
 
-define KernelPackage/ata-oxnas-sata
-  TITLE:=oxnas Serial ATA support
-  KCONFIG:=CONFIG_SATA_OXNAS
-  DEPENDS:=@TARGET_oxnas
-  FILES:=$(LINUX_DIR)/drivers/ata/sata_oxnas.ko
-  AUTOLOAD:=$(call AutoLoad,41,sata_oxnas,1)
-  $(call AddDepends/ata)
-endef
-
-define KernelPackage/ata-oxnas-sata/description
- SATA support for OX934 core found in the OX82x/PLX782x SoCs
-endef
-
-$(eval $(call KernelPackage,ata-oxnas-sata))
-
-
 define KernelPackage/ata-pdc202xx-old
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Older Promise PATA controller support
@@ -377,7 +361,7 @@ $(eval $(call KernelPackage,md-raid10))
 
 
 define KernelPackage/md-raid456
-$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor)
+$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor +LINUX_4_4:kmod-lib-crc32c)
   TITLE:=RAID Level 456 Driver
   KCONFIG:= \
        CONFIG_ASYNC_CORE \
@@ -657,7 +641,7 @@ $(eval $(call KernelPackage,scsi-cdrom))
 
 
 define KernelPackage/scsi-tape
-  SUBMENU:=$(OTHER_MENU)
+  SUBMENU:=$(BLOCK_MENU)
   TITLE:=Kernel support for scsi tape drives
   DEPENDS:=+kmod-scsi-core
   KCONFIG:= \