kernel: fix crypto-hw-geode dependencies
[openwrt/staging/chunkeey.git] / package / kernel / linux / modules / crypto.mk
index 065ddbfecb3cbc82ee63e9a518143d190e81cb7a..32332ef6b3768cd13a28cd642fddadec4388a9fd 100644 (file)
@@ -135,7 +135,7 @@ $(eval $(call KernelPackage,crypto-hw-talitos))
 
 define KernelPackage/crypto-hw-padlock
   TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
-  DEPENDS:=+kmod-crypto-aes
+  DEPENDS:=+kmod-crypto-aes +kmod-crypto-manager
   KCONFIG:= \
        CONFIG_CRYPTO_DEV_PADLOCK \
        CONFIG_CRYPTO_DEV_PADLOCK_AES \
@@ -152,6 +152,7 @@ $(eval $(call KernelPackage,crypto-hw-padlock))
 
 define KernelPackage/crypto-hw-geode
   TITLE:=AMD Geode hardware crypto module
+  DEPENDS:=+kmod-crypto-manager
   KCONFIG:= \
        CONFIG_CRYPTO_DEV_GEODE
   FILES:=$(LINUX_DIR)/drivers/crypto/geode-aes.ko
@@ -164,7 +165,7 @@ $(eval $(call KernelPackage,crypto-hw-geode))
 
 define KernelPackage/crypto-hw-hifn-795x
   TITLE:=HIFN 795x crypto accelerator
-  DEPENDS:=+kmod-random-core
+  DEPENDS:=+kmod-random-core +kmod-crypto-manager
   KCONFIG:= \
        CONFIG_CRYPTO_DEV_HIFN_795X \
        CONFIG_CRYPTO_DEV_HIFN_795X_RNG=y
@@ -386,6 +387,7 @@ define KernelPackage/crypto-misc
   FILES:= \
        $(LINUX_DIR)/crypto/anubis.ko \
        $(LINUX_DIR)/crypto/camellia$(camellia_mod_suffix).ko \
+       $(if $(call kernel_patchver_ge,3.7),$(LINUX_DIR)/crypto/cast_common.ko) \
        $(LINUX_DIR)/crypto/cast5$(cast56_mod_suffix).ko \
        $(LINUX_DIR)/crypto/cast6$(cast56_mod_suffix).ko \
        $(LINUX_DIR)/crypto/fcrypt.ko \
@@ -464,7 +466,7 @@ define KernelPackage/crypto-null
   KCONFIG:=CONFIG_CRYPTO_NULL
   FILES:=$(LINUX_DIR)/crypto/crypto_null.ko
   AUTOLOAD:=$(call AutoLoad,09,crypto_null)
-  $(call AddDepends/crypto)
+  $(call AddDepends/crypto,+kmod-crypto-manager)
 endef
 
 $(eval $(call KernelPackage,crypto-null))
@@ -474,7 +476,7 @@ define KernelPackage/crypto-test
   TITLE:=Test CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_TEST
   FILES:=$(LINUX_DIR)/crypto/tcrypt.ko
-  $(call AddDepends/crypto)
+  $(call AddDepends/crypto,+kmod-crypto-manager)
 endef
 
 $(eval $(call KernelPackage,crypto-test))