treewide: cleanup kernel symbol references
[openwrt/staging/blocktrron.git] / package / kernel / linux / modules / crypto.mk
index 446801ae233600ee345319de859f7b00dc98650a..a3785d26fd04b8826f82b2bb78c7d12453004057 100644 (file)
@@ -824,9 +824,7 @@ $(eval $(call KernelPackage,crypto-rmd160))
 
 define KernelPackage/crypto-rng
   TITLE:=CryptoAPI random number generation
-  DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac \
-               +LINUX_5_10:kmod-crypto-sha256 \
-               +LINUX_5_15:kmod-crypto-sha512
+  DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha512
   KCONFIG:= \
        CONFIG_CRYPTO_DRBG \
        CONFIG_CRYPTO_DRBG_HMAC=y \